GL-AR300M Shadow: Upgrade to firmware 4.3.6 failed

I tried to update my fairly old (2018?) GL-AR300M Shadow with 16 MB NOR and 128 MB NAND flash to latest firmware 4.3.6.
Apparently the U-Boot release of the device was too old in order to install firmware 4.3.6 (NAND - img-file from https://dl.gl-inet.com/?model=ar300m).
Thus the first attempt to upgrade the firmware failed prematurely.
Flashed the current U-Boot release from https://github.com/gl-inet/uboot-for-qca95xx/tree/master/bin successfully afterwards.
New U-Boot is undoubtedly active since the U-Boot Web UI has been changed.
Started over again. Flashed firmware 4.3.6 (NAND) via U-Boot Web UI a second time. Flashing seemed to be successful now. However, booting to firmware 4.3.6 failed - nothing happened.
Switched back to previous firmware by flashing 3.216 via U-Boot Web UI again. Rebooting was successful. Device booted up with firmware 3.216.
Next attempt: Tried local upgrade in web Admin Panel. Fetched the „tar-package“ for 4.3.6 and uploaded/installed the package with no success.
The device didn’t boot to firmware 4.3.6 hereafter. Subsequent upgrade via U-Boot Web UI didn’t changed anything.
I decided to install the old firmware 3.216 again. Worked flawlessly - 3.216 is up and running.
Since my GL-AR300M Shadow is pretty old, I suspect that the device (hardware) is not compatible with the current firmware (4.3.6).
Are there any restrictions for firmware 4.3.6 with respect to the hardware release (“age”) of the device?
Are there additional prerequisites - others than the U-Boot release - to consider?

Best regards
Bernd

It has nothing to do with the uboot version.

I have verified this upgrade and there is no problem.

That’s interesting. Some more details from my side:
With the old U-Boot release any attempt to update to 4.3.6 failed prematurely.
This issue disappeared after the U-Boot upgrade and flashing of firmware 4.3.6 (NAND) via U-Boot Web UI is obviously executed.
Unfortunately the device will not boot to 4.3.6 afterwards.

Best regards

Bernd

I ran into this last week when I tried to update a new to me ar300m (NAND) that was stuck on 2.215 and ended up corrupting the NAND software.
This is how I eventually fixed it.

After risking updating uboot to the newest version. I installed vanilla openwrt to the NOR partition and the from within openwrt I was able to successfully flash the full (NAND/NOR) 4.3.6 firmware.

It was a lot of trial and error to discover this method but it finally worked and my ar300m has been reliably booting 4.3.6 from NAND ever since.

Good luck!

@Toernfoernix @Randomstart

I verified both versions of the uboot,Which uboot version did you use?

1692846140006_ADC17315-0D08-4f53-BC9C-47A79F66DC6D

I used the latest one available on the github which is 22.02.16.

Currently my GL-AR300M Shadow uses the U-Boot release 22.02.16 - most recent one.
The original U-Boot release had no version/release number at all.
More precisely: Initially - before I updated to 22.02.16 - there was no version/release info on the U-Boot web page. I assume that the U-Boot release was a very early version for GL-AR300M.

A short update: Carried out a few further checks and continued the assessment.
As expected the upgrade to 4.3.6 is generally functioning.
However I’ve to deactivate DHCP and set the router IP (192.168.8.1) manually.
That’s a little bit strange, cause with 3.216 usage of DHCP was no problem; same for the most recent
OpenWRT release (https://downloads.openwrt.org/releases/22.03.5/targets/ath79/nand/).
Furthermore, after logging successfully to Admin Panel at 192.168.8.1 WIFI seems to be non-existing anymore; even in LuCI there’re no indications for a WIFI support.
The „WIRELESS“ page is completely empty and the „INTERNET“ page seems to be broken;

2023-08-26_GL-AR300m

Router name is by default „GL-„.
That all looks like an invalid configuration. I’m aware that an old configuration of OpenWRT 19.x cannot
be migrated to OpenWRT 22.03.
Thus I tried to get rid of old „configuration leftovers“. Installed 4.3.6 from Admin Panel and U-Boot Web GUI multiple times - with no success. The configuration remains faulty.
Have still to deactivate DHCP and WIFI is „lost“.

I have also been unable to upgrade ar300m firmware from 3.216 to 4.3.7.
It gets stuck on “verifying” in the GLI UI.
Is there a recommendation as to whether or not to perform this upgrade?
If yes, what is the recommended way to accomplish the upgrade?
Thanks,
Ari

Same Problem here. Is here anyone how has successfull updated his ar300m to 4.3.7? And can maybe tell me if there is any benefit on this one?

EDIT: Got it, downloaded wrong firmware. I assumed i had a AR300M, but i have a AR300M16 … with the other firmware its working now. My confusion was about that the Webinterface said AR300M and on the device itself on the back said AR300M16.

I see you got your router working.

I upgraded one of my ar300m from 3.216 to 4.3.7. I’m configuring this router as a VPN server to work behind a NAT firewall, so it will proxy through a VPS that has a static IP address. As I expect this router to run for several years unattended, I wanted to start with a new firmware base. After a day of looking at the GL iNet 4.3.7 firmware, finding it was missing some packages I needed, I gave up, and tried the last beta of OpenWrt 23.05 firmware. That worked so well, that I have upgraded to the released version of OpenWrt 23.05.0 and will use it instead of GL iNet firmware for this application.

I am amazed at how little flash space I needed to support OpenVPN, SoftEther and Wireguard services on OpenWrt 23.05. I could easily fit this configuration into 16MB of flash.

Thank you - it looks like I was trying to use the AR300M16 firmware whereas my router was an AR300M. Have downloaded the fw for the 300m and now the upgrade proceeds without error.