GL-AR300M - WiFi turns off automatically



I am using a GL-AR300M in Client and AP Mode(Master).

Sometimes the wifi in client-mode disables itself for no reason, while the AP-mode is still enabled.

I tried to use watchcat to force a reboot when the GLAr300m cant ping to googles server, but even after a reboot the wifi in client-mode is still disabled.

I really have to enable the wifi manually.

Is there any way to fix this?

That would help me a lot.


Firmware: 2.263

Do you have “Auto scan & reconnect” checked under “Internet Settings”?

Thanks for your reply. Yes, that setting has already been checked.

Thats why I am wondering why it wont connect after a while and even after rebooting the device.

I would try changing your main ISP router’s wireless channel.

Mhm…why would that help to solve the problem?

Anyway, I cant change the channel as long as the main router is a public (Wpa2) wifi (Hotel).



This is working as designed for client/ap mode.

Basically it is working as a forwarder and if the client part fails to connect/authenticate to the remote ap then there is nothing to forward so the ap wireless is switched off.

If you want it to stay on all the time try configuring as client/ap(wds) instead. This means the local ap will set up to forward itself downstream using wds and therefore be abailable at all times with the client part picking up the remote ap if available.

Thank you so much. I will give it a try and report within the next days.

In the default firmware there is a repeater manager watching the connection. If the client is not stable for several times, the router will disable the sta so that AP will be enable without problem.

In /etc/rc.local, the repeater manager (gl_health) is started each reboot. It will also start if you change sta settings.

To disable this, change /usr/bin/gl_health to another name

1 Like

Thanks for your reply.

I renamed the file and will report back in the next days if that solved the problem or not.

After three days the problem seems to be solved.

The client mode has not been disabled since then.

I changed the ap to ap wds mode and deleted the file in /usr/bin/gl_health.

Thank you very much, guys.

I have the same problem, I’m using a mac, I dont where to locate this file, please teach me

This is a problem from 3 years ago. You’d better open new thread.

Firmware has been updated several times to problem will be different.