GL-AR300M will not connect to VPN

I have just received a GL-AR300M and cannot get it to connect to FinchVPN. It constantly displays ‘Please wait…’ irrespective of what server I choose or what UDP or TCP config file I download from FinchVPN site. It has latest firmware 2.24. Could someone please give me some advice on how to resolve this?

I have followed the instructions here and it does not work: Overview - GL.iNet Docs

I have resolved the issue. I changed my password on FinchVPN website and ticked ‘Enable password login for VPN (You will be able to login with API key or FinchVPN password)’

thanks for reporting this issue.