GL-AR300M16-ext: No cable detected in WAN

Hello,

There is an issue with the WAN port on this router - it doesn't recognize the connection of the gigabit cable. An important note: the gigabit cable going into the router comes from a PoE injector (from the port that doesn't supply power).

Here's what I have done so far:

  1. The firmware was 4.3.11 - downgraded it to 4.3.7.
  2. Through SSH, I set "speed 1000 duplex full autoneg on" for eth0 and eth1 (just in case, one of them should definitely be the WAN).
  3. The MAC address is set to the one known by the provider.
  4. Tried both my cable and the provided one with GL-AR300M16-ext - same result.
  5. My gigabit cable works, as it is currently connected to an ASUS TUF-AX5400 and sometimes needs to be connected to another mini-router (a 10-year-old Chinese no-name) - everything is fine with them.
  6. Connected the provided cable to the LAN of the ASUS TUF-AX5400 and to the WAN of the GL-AR300M16-ext - everything works, my router assigns an IP, and the GL-AR300M16-ext distributes the internet.

I have logs, but I didn't find anything useful there.
What am I missing? How can this be fixed?

Both ports are only 10/100.

Certainly. I don't expect the throughput to be 1000. I'm happy with 100. but the WAN port doesn't work with either a gigabit cable or the included 100.

Seems that your PoE device does not support 100 Mbps?

Supports. "a 10-year-old Chinese no-name" mini-router exactly works via WAN 100 megabit.

10-years ago there was 1 Gbps as well, are you sure that this device does not support 1 Gbps?


It's not about the absolute speed but about the auto-negotiation. Does the china one provides 1 Gbps on max?

The "china router" definitely has WAN-port of only 100 megabits.

I have connected the WAN port of my GL-AR300M16-ext with 4.3.11 default configuration to a Cisco SG200-08 gigabit switch. It auto negotiates and connects at 100 Mbit. The switch has one POE port and also non-POE ports. I am not home right now. I don't remember if I used a POE port on the switch, but I did not use a POE splitter and I think I plugged into a non-POE port.

I forgot an important point that radically changes the essence of the problem - after downgrading the firmware, the cable began to be recognized, but the address from the provider via DHCP is not assigned :blush:

Maybe you need to add the VLAN tag to your connection?

I'm not sure this will help. What will the VLAN in my case give me?

Only the ISP knows. Maybe 5, maybe 7, maybe something else.

Would that not cause a negotiation issue?

Why? Otherwise, the ISP will not issue an IP address to my router.

When you plug the cable to the WAN, can you check kernel and system log if there is anything?

WAN should be eth0

I took fresh logs. I don't see anything useful there. Can I share with you in a PM, maybe you can understand it better?

yes pls pm me your log.

The issue was resolved :grinning: - I set static configurations for the WAN port. However, the final question "why the WAN is not receiving an address via DHCP from the ISP" remains relevant (although WAN port receives an IP address from other equipment) :thinking:.

By the way, I tried different versions of the firmware and wrote to support about vlans - to no avail.