I see this device is advertised as capable of having txpower=20dbm and yet, it seems to be fixed at a maximum of 12dbm, regardless of country setting

Could you explain why? I bought 2 of these devices in Amazon and I think I will return it but before I do I wanted to ensure I ask you why it is set to 12dbm. If you can tell me how to change it so I can achieve the advertised tx power settings, I will keep them.


1 Like

ssh -oHostKeyAlgorithms=+ssh-rsa root@
Enter your personal set password.

root@GL-MT1300:~# vim /etc/config/wireless

search for the entry: option txpower '20' … In my Beryl with Firmware 3.203 this is the default.
The other important line is option country 'DE' (Default: ‘CN’) … This two-letter-code sets some limitations, given by law in this country.

Thanks for the feedback. However, I have already tried settings with multiple countries and multiple tx power options modifying the config wireless file via ssh.

It remains fixed at 12dbm. Most European countries should allow to go up to 20dbm (100mW), but I also tried Slovenia, Japan, and Kenya which have higher allowed tx power just to test. Tried setting 14,16,18,20dbm and no change. Always stuck at 12dBm

Here is the output of the last setup that I did with country slovenia

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ‘11g’
option path ‘platform/ahb/18100000.wmac’
option txpower_max ‘20’
option band ‘2G’
option txpower ‘18’
option htmode ‘HT20’
option channel ‘auto’
option beacon_int ‘200’
option disabled ‘0’
option country ‘SI’

reloaded wifi

and this is the iwconfig

wlan0 IEEE 802.11 ESSID:“IsolaAlbarellaWifi”
Mode:Managed Frequency:2.412 GHz Access Point: 00:3A:7D:0B:41:E0
Bit Rate=39 Mb/s Tx-Power=12 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=35/70 Signal level=-75 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:171 Invalid misc:485 Missed beacon:0


I’m not so sure about the behavior of the GL.iNet devices. But I think the settings from /etc/config/wireless will be written to /etc/*/*.dat during reboot. I haven’t mentioned the reboot before.

Here the check for my Beryl:

root@GL-MT1300:~# grep -i country /etc/Wireless/RT2860/RT2860_5G.dat

as I now, the countrycode needs to be uppercase.

My GL-AR300M16-Ext in Canada shows Tx-Power=20 dBm on Channel 11

I do not work for and I am not directly associated with GL.iNet

Nice throughput…! as you can see on my screenshot and signal quality, I do need to try at higher tx power levels to see if I can improve performance. Already tried a few different antennas. 12dBm wont do.

I am thinking it is this unit I bought. I read some issues on other forums with low tx power. This is a deal breaker for me and units are going back to amazon if I cannot get at least 18 dbm out of these units.


BTW, I can go down and it get set fine, tried 10dBm it worked like a charm. But anything about 12dBM it just doesnt work

Have you upgraded to the latest firmware version? Before returning then to Amazon, it may be worthwhile dong a factory reset and checking one more time (stranger things have happened :grinning:).

Weird… I found this thread just now trying to figure out why a completely different radio is also stuck at 12dBm despite being on the latest firmware and capable of plenty more, and despite it being legal in my jurisdiction.

You can try installing (i.e., downgrading) to Firmware 3.203, which is working for me.

I use 23dbm on an AR300M16-ext. Country code-00. No problem.