GL-AR300M16 openwrt 22.03.0 rc5 USB port power off by default

I built openwrt v22.03.0-rc5 for my gl-ar300m16 and it works except for the power to the USB port.

It seems like mainline openwrt needs a patch to connect the USB GPIO power supply to the USB port for the GL-AR300M16 target?

Searching these forums i see there was a similar issue a few years ago between gl-inet firmware 2.26 and 2.27 USB devices not recognized - #8 by patchmaster

I suspect the same patch is required for mainline openwrt?

I didn’t test openwrt 22.03 on AR300M16.

But if the USB is powered off by default, a simple solution is to enable it in /etc/rc.local

Just write a command to enable the USB, e.g. writing 0 or 1 to the gpio control.

Yes i tried that but couldn’t export GPIO 2 (i suspect with the new 5x kernel its not actually gpio 2 but called something else)

Anyway i managed to get it to work by creating this patch:

diff --git a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m.dtsi b/target/linux/ath79/dts/qca9531_glinet_gl-ar300m.dtsi
index d64ffa7115..5aaa149940 100644
--- a/target/linux/ath79/dts/qca9531_glinet_gl-ar300m.dtsi
+++ b/target/linux/ath79/dts/qca9531_glinet_gl-ar300m.dtsi
@@ -43,8 +43,7 @@
                regulator-name = "usb_vbus";
                regulator-min-microvolt = <5000000>;
                regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 2 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
+               gpio = <&gpio 2 GPIO_ACTIVE_LOW>;
        };
 
        leds {
3 Likes

Did you already mentioned this on github for openwrt, so this bug can be fixed in the next bulids?

No, i didnt, you will need to submit a patch to openwrt mainline

We will do that. Thanks!

2 Likes

Could you please post the link here to your corresponding pull-request as soon as created?
→ I urgent need a fixed firmware and would be happy, when this bug is fixed in the next openwrt release (>22.03.2).
Thanks in advance!

1 Like

Developer will post link of pull request after submit.

Please give a little time.

Problem finally solved. Pls check the patch.

It is due to a driver issue actually.

Openwrt merged the patch to master.

(post deleted by author)