GL-AR300M16 VPN Client connects fine; but cannot RDP into a PC on the network

I am trying to get the VPN client working on the GL-AR300M16.
My configuration -

  • VPN Server (OpenVPN) enabled on a TP-Link Archer 9 Router.
    Lan IP/Subnet Mask: 192.168.1.? /
    VPN Subnet/Netmask: /
    This VPN server has been verified to work with other VPN clients (such as an OpenVPN Connect installed on a Windows PC).
  • GL-AR300M16 (No changes out of the box). Connected to another network through WiFi.
  • Windows 10 PC connected to GL-AR300M16 through WiFi. Internet connections work fine before connecting a VPN Client.

VPN Client was added using the VPN config file from the VPN Server.
The VPN client connects to my VPN server fine. Then, the issues start.

Once the VPN client is connected, I can go to some websites, but not to all. For example, I can go to, but not to
While trying to RDP into a machine on my LAN (that the VPN server is on), it pops up the prompt for password (so it is doing something), but then it gets hung on “Securing Remote …” forever.

Can you help? Is there some setting that I am missing ?

This seems a mtu problem.

Is there any mtu config in the ovpn?

Thank you for that lead. I did some read up on MTU. There was no MTU in my openvpn config file. I added a line for “mssfix” and tried with different values for it. Even after reducing it to a very low value as 500, I still face the same issues.

Again, everything works fine when I use an OpenVPN Connect client on a PC that uses the exact same connection that is used by the GL-AR300M16 and the exact same openvpn config. Adding the GL-AR300M16 with the VPNClient introduces this issue.

I am getting the feeling that there is something (a configuration, may be?) missing on GL-AR300M16.
Thanks for your help.

I have seen this issue in the past with some OpenVPN servers. What has worked for me is to use the OpenVPN TCP protocol instead of UDP. You may have to change your OpenVPN server to do this, and change your config file. Its not the best fix, as TCP has its own set of issues, but I have gotten around the problem of passing large packets by when using UDP on some OpenVPN servers.

I face the same issues on both Gl iNet routers I have. My Android client, Linux (PC) and windows (PC) clients can connect successfully connect to my VPN server (I created one using an Asus router) and access internet without any issue. Unfortunately, using the same .ovpn client file with the AR300M and the E750 I can’t get the same results. The routers connect to the server, the pings to any address are ok but that’s it, no full internet access that allows me to browse. Could it be that the 3.211 version is buggy? With the AR300M on the previous firmware I was able to use this same .ovpn client file without any issue.