GL-AR750 and QoS with LuCI OpenWRT 18.06


#1

I’m afraid I made a huge mistake.

Recently, I upgraded my GL-AR750, from LuCI LEDE 17.01, to OpenWRT 18.06

I do like the OpenWRT GUI, and I belie I understand this interface much better.

But please note that I am a beginner in everything related to openwrt, Linux, etc…

Anyway, I had managed to configure the QoS that suited me in the LEDE GL-AR750; in order to make some devices priority to others, but without using band limitation.

After de upgrade, I’m no more one LEDE, and I don’t find any QoS configuration, except de one in the “client” page (http://192.168.8.1/index#/clients)

But this one only provides band limitation.

And I don’t want to limit any device bandwidth, if there is no other (priority) device using bandwidth.

I don’t know coming back to LEDE.

I read about it, and it scared me.

And I don’t want to change, cause I like that OpenWRT.

But I need a good QoS service. Too many devices are connected on my DSL connection, and some use all the bandwidth while I would like to have 75% on the main computer.

I did find luci-app-qos, or others qos applications (?), but event with a tutorial, I’m not sure how to make it work, or what it will provide.

I connected to the GL-AR750 with WinSCP for the first time only 24 hours ago.

For example, I don’t understand what’s called “enabling the qos init script” and the rest here: https://openwrt.org/docs/guide-user/network/traffic-shaping/qos-tomerge

So… do you think someone can help me get a QoS configuration interface such as LuCI LEDE

Please ?

In the meantime, I’ll try… whatever I can find.

Hopping it won’t brick my router.

But that wouldn’t be the worst thing.

Thank you.


#2

When you upgrade, you typically need to reinstall any packages you’ve installed that aren’t part of the ROM.

Do you have luci-app-qos and qos-scripts showing in your list of installed packages? If not, installing the first (the GUI components) should bring in the rest.

The link you provided also indicates that

NOTE: luci-app-qos won’t start until you enable the qos Initscript within the System–>Startup tab as well as enable qos under Network–>QoS

so checking that they are enabled would be worthwhile as well.


#3

Hello jeffsf,

Thank you very much for your answer.

I didn’t know anything about this package thing after an upgrade.

However, I already tried to install "luci-app-qos" last night.

After searching for it in the available package, in the "software" page, the "install" button next to the package name seemed to do nothing.

I then discovered and tested this night, at 2 am (Paris time) "download and install package" and put the names that luci-app-qos and press "ok".

And it worked!!!

In the MENU NETWORK, I now have the QoS section.

And it’s the same page I had before (upgrade)

After reading you, I checked : I do have qos-scripts, and it’s fine.

But as you write, it was probably the installation of the first one that set up the second one.

I checked in the LuCI interface, Startup section: I have the “qos” element (I think that’s it).

And I understood what the part with the network means: of course, you have to activate the QoS in the Qos page.

Now, the question is whether I will have a conflict of different QoS packages, and whether I should disable a package.

Maybe the "glqos" version 3.0.15-1?

Well, it’s 3:44 a.m., have to go to bed.

Thank you very much jeffsf


#5

The problem is solved, since I have access to the QoS configuration I know.
I have more questions, but I’m going to open a new post.
Thk.