GL-AR750 as Switch

Hi everybody,

I bought a AR-750 and I would like to use it as a switch (cable / WiFi).
I work in motorsport and basically I would like to connect to the ECU (that use an ethernet connection to communicate) through WiFi so that I don’t need to connect to the car to modify calibrations or to download data from it.

If I connect the ethernet cable of the ECU to one of the two ethernet ports (not the WAN port) I can access to the ECU from any computer through the WiFi connection, however if I try to connect to it through the second ethernet port it doesn’t work.

The main issue is that when I download data from the ECU the connection isn’t very stable and sometimes I lose some data, for this reason I would like to maintain both the connection (cable and WiFi).

It seems like the AR750 is working as a switch just between one ethernet port to WiFi.

Can you suggest me something to try to solve my problem?

Thank you!


I am also interested in this issue. MY AR-750 does not allow LAN port to LAN port traffic, ie using the LAN ports as a switch. As the previous poster mentions WiFi to LAN works fine and LAN to WiFi works fine.

I suspect the problem is related to the firewall settings. Any recommendations?

You can upgrade to v2.27, which is available in GL.iNet download center


v2.27 does not correct the problem. There is definitely something preventing traffic from passing directly between the two (2) LAN ports.

I even reconfigured the device to be an access point by adding Eth0 (WAN) to the LAN bridge and disabling the firewall and DNSMasq services. With Eth0 added to the LAN, traffic flows to/from either of the LAN ports and Eth0 and WiFi. However, LAN port to LAN port traffic is still prevented by something. Very strange.

When you upgrade to v2.27, don’t reserve settings.

The settings from the old firm made the LAN-LAN talk failed.

Now you can try a revert in Firmware.

After the update the wired network switching works, however just between WAN and LAN ports and not between the two LAN ports.

By the way it solved my issue! I can connect to the ECU through WiFi and also through wired LAN.

Thank you so much!

Resetting to Factory Defaults after updating to V2.27 did indeed resolve the issue. I now have connectivity between the two (2) LAN ports directly.

Thank you for the suggestion.

Sorry for my bad english.
I solved the problem by editing (through ssh) the “/etc/config/network” file and inserting the following lines at the top:
config ‘switch’ ‘eth1’
option ‘enable’ ‘1’
option ‘enable_vlan’ ‘1’
option ‘reset’ ‘1’

config ‘switch_vlan’
option ‘vlan’ ‘0’
option ‘device’ ‘eth1’
option ‘ports’ ‘1 2 0t’

after saving the changes and reboot the ports now work.