GL-AR750 drops 5G connection - router mode, 5G WAN

Hi, need some help please, I have a new GL-AR750 updated to the latest firmware and reset, bought this for travel and to get setup in hotels easier.

When I connect to a 5G WIFI wan to share I am having issues in router mode.

Basically, connect to the 5G wan, then connect to the router via the local 5G wifi connection and the router freezes and reboots - usually the moment I try to upload anything.

This should be an easy setup but every time I use a 5G WIFI lan the router becomes unstable.


Can you change one power adapter?

How about 2.4G WiFi? Do you have such problems?

1 Like

Hi There, thanks for the reply.

I did try the power adapter that came with the router, also tried two others with the same results.

Using 2.4G as the wan connection and 5G as the local connection worked, but was slow.

A possible fix was to go back to firmware 3.105 - with this version I could use 5G as the WAN and local connection. Throughput is not impressive (half of what my TP-Link does in the same conditions) - but it works.

Is this a known bug that’s being looked at in the firmware?


Actually there is no explicity bug from testing and user feedback on this model.

Okay, wondering how I open a ticket to look in to this bug because there is one and there are other threads with the same issue.

Using 5G as a wan connection with a 5G local client breaks once you upgrade from 3.105 to 3.203 and beyond.

I can replicate the issue every time without a miss, it’s a 100% failure rate after upgrading the firmware.

Others have posted that they use 2.4G for the WAN connection and 5G for local clients which works, but this will not work for my network - also 2.4G is slower. I even see Amazon reviews with people returning the router for the same reason.

This is a basic function that should work… happy to help share info from my side.


I have a GL-AR750S and my WLAN sometimes drops when running both WWAN and WLAN on 5GHz. This happens more when there is higher traffic from downloading. The router does not actually freeze, nor reboot and I am able to manually reconnect WLAN again.

It is more stable when WWAN and WLAN are on different bands. Since it is only a travel router for me, I can live with that.

I am on firmware 3.211 and using 5G to repeat and broadcast wifi. It works OK. I wonder if you can reset your firmware and just try again?

Thanks - same issues as I have but using 2.4G as the wan is not an option for me.


Hi, I upgraded again to the latest firmware and have the same results.

Before upgrade things work with 5G WAN and 5G local client.

Upgrade, with 5G WAN then connect with 5G local client. Then run speed test. Download is good and fast, during upload 5G WAN and LAN connections drop.

Try to connect to 5G LAN again and sometimes works with either no or very slow 5G wan connection. **Update - the 5G lan comes back up after crashing but the WAN does not.

Log files attached.

I have reset to default many times, this does not help.

I will need to downgrade again to make the router usable with 5G WAN.

system (14.3 KB)

Just to avoid delays… log files with exact same disconnect results after a full reset and re-configuration of the router are attached.

system log after (10.7 KB)

@alzhao Any thoughts on the log files please?

I can replicate this issue at any time at different locations with different host networks.

ON 14:23 it was broken and reconnected 14:25.

It was broken because there is udhcpc renew failure. If the main router is your own router, can you set the dhcp lease time longer? Now it is 2 hours. The router will renew every per hour.

@alzhao did you see the same thing on both sets of log files? And - should the router not return to full speed once the IP Address is renewed?

This can’t bee a DHCP error as I have tried the same thing on four different networks - the failure happens immediately after connecting so there is no way the IP address could be timed out by the router.

Again - this failure can be recreated on any network, the 5G connection remains down after it drops, and it occurs right after the router is turned on. Also, why is this not a problem on the older firmware?

Please consider other causes, do you need more log files?

Hi @alzhao did a complete reset and reload of the firmware, also connected to a router with a much longer dhcp lease time.

As you can see i can recreate the issue on-demand within minutes of setting up a fresh router and while connecting to any 5G host wifi connection.

New log files attached, you will notice the WAN crash at ~15:37.

Process is the same:

  1. reset router and reload fresh firmware
  2. connect to router and connect to 5G WAN
  3. update plugins, load luci, set time
  4. connect to router with 5G wireless client
  5. run speed test
  6. WAN dropped when upload test starts.

Please see log files again. Interesting to see the same feedback on Amazon reviews now.

logs with 4 hour dhcp wan fresh (18.3 KB)

Recreated again on a different host WAN

Mon Jan 31 17:59:16 2022 kernel: [ 268.220233] br-lan: port 2(wlan0) entered disabled state
Mon Jan 31 17:59:16 2022 kernel: [ 268.229283] wlan-sta: deauthenticating from 00:31:92:eb:f4:17 by local choice (Reason: 3=DEAUTH_LEAVING)
Mon Jan 31 17:59:16 2022 daemon.notice netifd: Network device ‘wlan-sta’ link is down
Mon Jan 31 17:59:16 2022 daemon.notice netifd: Interface ‘wwan’ has link connectivity loss
Mon Jan 31 17:59:16 2022 daemon.notice wpa_supplicant[6573]: wlan-sta: CTRL-EVENT-DISCONNECTED bssid=00:31:92:eb:f4:17 reason=3 locally_generated=1
Mon Jan 31 17:59:16 2022 daemon.notice wpa_supplicant[6573]: wlan-sta: PMKSA-CACHE-REMOVED 00:31:92:eb:f4:17 0
Mon Jan 31 17:59:16 2022 daemon.notice netifd: wwan (6672): udhcpc: received SIGTERM
Mon Jan 31 17:59:16 2022 daemon.notice netifd: Interface ‘wwan’ is now down
Mon Jan 31 17:59:16 2022 daemon.notice netifd: Interface ‘wwan’ is disabled
Mon Jan 31 17:59:16 2022 daemon.notice netifd: Interface ‘wwan’ is enabled
Mon Jan 31 17:59:16 2022 daemon.warn dnsmasq[2757]: no servers found in /tmp/, will retry
Mon Jan 31 17:59:19 2022 daemon.notice netifd: Network device ‘wlan0’ link is up
Mon Jan 31 17:59:19 2022 kernel: [ 271.510668] br-lan: port 2(wlan0) entered blocking state
Mon Jan 31 17:59:19 2022 kernel: [ 271.516232] br-lan: port 2(wlan0) entered forwarding state

@alzhao your feedback please on additional log files and examples.

It is Chinese New Year holidays.

1 Like

Thanks for the detailed report. I did test using AR750 and 3.211 today and I can replicate this problem.

I think this is related to the encryption the upstream router using.

My upstream router is using wpa3 and I have this problem. When I set upstream router to wpa2 it works OK. Is this your case?

I filed a bug internally about this.

1 Like

Hi, Thanks so much for confirming and for filing a bug report. Hopefully it’s an easy fix :).

I forced my upstream router to WPA2 but the AR750 still crashed. The trigger seems to be a larger upload so I can force the bug on-demand by running a speedtest. The download works perfect, but the upload test crashes the router.

Thanks again, looks like the fix for now is to use the older firmware.


I saw this. But let just wait for our developers to test and fix.

1 Like