GL-AR750 Synology NAS Internet access


#1

Hello, I have a GL-AR750 and is set up as a router network mode.

I have connected it to a 5G Wifi network for WiFi access.

The router IP is 192.168.0.1 with a mask of 255.255.255.0
The Wifi IP is 192.168.1.1 with a mask of 255.255.255.0

Everything works just fine. Devices connected to my GL-AR750 via wifi or cable can access the internet just fine.

But my Synology NAS (upgraded to the latest version can’t).

I have check the network settings on my NAS and I have a DNS a gateway set and all is fine. Even with DHCP enabled I can get a proper IP. But when I try to connect to internet it says it is not connected to the internet and fails.

I have changed the DNS to be google one 8.8.8.8 and the openvpn ones also none of them work.

I took my NAS and connected it to the main router that supplies the Internet, made no changes and now it works.

So the conclusion here is that my connection from my NAS doesn’t go through GL-AR750. Is there something I am missing?

My GL-AR750 is doesn’t have any other changes done to it, apart from the IP to be 192.168.0.1.

Forgot to mention that when my NAS is connected to GL-AR750 I can access it, I can see the UI make changes to it etc, it just doesn’t connect to the internet.


#2

Would it caused by IP conflict? What’s the subnet of your NAS?


#3

Hey @kyson-lok I have added it in my original post. The router with internet access runs on 192.168.1.1 with a subnet of 255.255.255.0, and my AR750 router is set to 192.168.0.1 with a mask of 255.255.255.0.

So they are on different subnets.

All my other devices work just fine, but my NAS when is connected to AR750 it doesn’t. If I move the network cable from my AR750 to my internet connected router it just works.

So there some conflict or something is blocking my NAS on AR750 level. Not sure where to start to look.


#4

I know it. What I ask is your NAS subnet. Maybe your NAS isn’t a router? I see most NAS has their own subnet.

If you change AR750’s subnet to 192.168.8.0/24, does it work?


#5

hello, sorry for the late reply. No it doesn’t.

I sorted my problem using another method with another router.

thanks.


#6

That doesn’t really help others with the same problem!


#7

Could you please share the method you used?


#8

I have bought another router that I configured to my needs. I then used the gl-ar750 to connect to the internet via wifi to my hallway ISP router and used a cable connection between the gl-ar750 and the router I bought. Basically adding into the WAN port the cable from gl-ar750.

This solve my problem for now, but there are 3 hoops and the internet speed degrades. For now it works, but I will eventually try a powerline adapter from the main ISP cable connection to the router I bought and decommission gl-ar750 from the network.


#9

Yup, but not sure why Slate doesn’t work with Synology NAS, it is strange.