GL AR750 with easytether driver

This is my first post, would like to say Hi! to everyone. Just got a new AR750 (creta) to play with. Using instructions on this web site to install driver to the router. Almost everything went smoothly until the part " v: easytether-usb " which stuck at error.

/etc/easytether/adbkey. : no such file or directory
acquired interface tap-easytether
no device match (see setup wizard in Easytether on your phone)

Please help me , what am I missing here?
Do all the programs , WinSCP, mobile phone need to be connected or open?

Really appreciate,
Thank you.

I has same adbkey problem with my Slate. Updating FW to 3.216 fixed that issue for me


My router firmware is 4.3.10,
Openwrt 19.07.3+ (tiny)
Windows 10.

Thank you for your input.

ipks from worked on my Slate(FW 3.216) and BerylAX(FW 4.5.0)

You might try upgrading/downgrading your Certa firmware

I will look into it. Been reading and reading here and there.
Thank you so much.

downgrade firmware to 3.2.16, but still have the same error…just give up for now…google so much now.
Thank you anyway.

heres some detailed info I wrote down last time I installed it on my Slate:

  1. On Router Web GUI:

    • connect to internet
    • Upgrade/downgrade FW to 3.216 (3.212 also works)
  2. On Windows PC connected to router:

    • use 7zip to extract zip to easytether-usb-tiny_0.8.9-5_openwrt-19.07.3/
    • open CMD.EXE in that directory
    • scp 19.07.3\ath79\tiny\easytether-usb-tiny_0.8.9-5_mips_24kc.ipk root@
    • ssh root@
opkg update
opkg install easytether-usb-tiny_*.ipk

cat << EOF >> /etc/config/easytether
while true; do
    if (ip a s tap-easytether up); then
        echo > /dev/null
    sleep 1

cat << EOF >> /etc/crontabs/root
@reboot sh /etc/config/easytether
  1. On Router Web GUI:

    Luci > Network > Interfaces > Add New Interface
    Name “easytether”,
    protocol “DHCP Client”,
    and select > Ethernet Adapter: custom “tap-easytether
    Assign the interface to the WAN firewall zone

    [ Save and Apply ]

  1. Reboot Router

  2. On Phone

    • Developer Options - enable USB Debugging
    • install EasyTether apk
    • Run EasyTether app and check USB
    • Plug phone into router (look for message “Allow connection from XXXXXX?” on phone)

Give it a few seconds and EasyTether should show “Connection Established” and you are good to go.

1 Like

Finally got it worked by using this method.

Need to edit root as described.
Fw.3.216 and ’ tiny ’ openwrt, Now I’m wondering if I updates fw, will it work?

Thank you so much for you support, got your idea to edit 2 files in ‘etc’ folder of router roots.

Thank you sooooo much.