GL AR750ext bricked


a few weeks ago i flashed my ar750ext using the web page to version 4.3.7 and after upgrading it to 3.216 it did work.
Today I connected the router again and after connecting the ethernet cable, powercable, there was no connection to the router.
I disconnected router, pushed reset button while powering on, 5G flashes 5 times and I let go.
Then the 2G LED went on but still no ethernet connection.
I tried several times but no luck.
Then I followed the unbrick manual and after awhile I got on the Unet FW page. I selected 4.3.7 and got UPDATE FAILED. Then I tried 3.216 and got the same error.

What posibillities do I have to recover this device?

Thank you very kindly, Tom

I tried uboot debrick also failed.
You can use the admin panel to do sysupgrade or downgrade.
The fist step is:
When system is fully booted, press more 10 seconds to Reset Firmware.

Hello, may I ask which interface you used to update the firmware in the link, or
In addition, there are two firmware options in the interface, and the firmware downloaded from the download site ends with bin, so you need to use the firmware in the NOR flash firmware.


thank you for your replies. After changing my W11 laptop with a Linux one, the connection remained stable and I could update/replace the firmware.
Now, after several days it remains stable on 4.3.7

Again, thank you for your help.

Greetings Tom

I’m glad your question has been resolved. If you have any further questions, feel free to contact us at any time.