GL-AR750S disabling LAN Ports


I have a problem with my travel router GL-AR750s. Im using it in WDS mode to integrate my PC in my local network. The PC is connected via LAN cable and is plugged in one of the ethernet ports.

So my problem is sometimes the GL-AR750s stops communicating over the LAN port and my PC loses connection. I looked up the Kernel Log and found following lines:

[ 48.142379] IPv6: ADDRCONF(NETDEV_UP): lo: link is not ready
[ 48.482008] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 48.601371] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 48.622783] br-lan: port 1(eth0.2) entered blocking state
[ 48.628373] br-lan: port 1(eth0.2) entered disabled state
[ 48.634336] device eth0.2 entered promiscuous mode
[ 48.639326] device eth0 entered promiscuous mode

It seems that the LAN ports are disabled for some reason. Do I need to change something to the interfaces? Can I enable the ports over an SSH connection?

I’ve been searching google and this forum lately, but never found a really suiting topic. That’s why I open a new topic.

Thanks for your help! :slight_smile:


This log is normal. Your log appears 40s after the device is powered on. At this time, the device initializes the switch. Therefore, these logs appear.
Can you provide a more complete log?


thanks for your answer.
I just let the AR750s boot today and this is the log:

“Failed to connect to the switch” seems to happen pretty often.


My problem is still alive.
I searched google for a while and disabled the firewall. This made it work constantly for about two weeks, before the problem came up again. Some restarts then made it work again. And today, after a week of no problems it suddenly have no connection to the switch again.

I am very sorry that I can’t provide a detailed log, but all it says is that it can’t connect to the switch.
Today at 20:32 the problem came up.
What could be the reason?`


Failed to connect to the switch for two days now. In corona times hard, when you can’t access the internet on your personal computer…

To provide some more information:

When the problem appears, I can’t acces to the router via cable. WLAN is working fine.

I have done a reset of the network pressing the the “reset button” for three seconds (Can someone actually explain what happens then? How can a network be repaired by pressing a button?) This did not solve thew problem.

I have done a firmware reset. This acutally solves the problem for some days. Then it starts again. I don’t want to reset my router once in a week.

I tried to flash the openwrt firmware. Not quite sure if this was successful. In my LuCI it says the firmware version is OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152). Online I’ve found some articles about Openwrt Firmware with the version 19.x.x.

Actually I’m messing around with this router since I ordered it in Summer 2019. I’ve tried every mode. Router mode drops wifi. Repeater and WDS mode drops switch connection.

Can someone help me troubleshoot and understand my problem?

Cant really help you with your problem exactly except for the reset button functionality and some generic advice.

Depending on how long you press the reset button, you have 3 functions:

  1. first three seconds (light flashes slowly) will reset wireless network and maybe LAN interfaces.
  2. next few seconds (flashing increases in speed) will reboot the router
  3. the following few seconds (flashing is now fastest) will reset to factory defaults.

If you cannot fix it for now you can set openwrt to do a Cron job to reboot once a week. Beware that you don’t have real-time clock in this router so this can cause issues.

My generic advice for fixing is just set up absolute most basic settings for a few days and see if that works. Slowly add more complexity to your configuration and then see if the problem still is at bay or if it resurfaces.

Generally, it is best to make openwrt settings as simple and leave them. If you need to change anything I find it can sometimes be more stable if you start from scratch each time.

Maybe it is really a hardware problem. Can you exchange one and check again?

You can label it and return to us for investigation.

Send email to cs at and cite this post. Thanks!