GL-AR750S ethernet stuck on 100baseT?

I have a AR750S running in access point mode which does about 150 Mbps on wifi, but I have one LAN client connected and it is stuck at about 80.

The problem seems to be that the link is only operating at 100baseT, which I verified both on the router and the LAN client. I tried both LAN ports on the router, and three different cables. The client runs at 1000baseT when I bypass the AR750S and plug it right into the ISP router with the same cable.

Is there anything I can do to try and force it to run at gigabit? Or any troubleshooting steps to find out why it decided on 100baseT?

I’ve heard adding a switch between two devices can sometimes help with getting them talking at 1000baseT. I’m not sure if this will help in your situation but worth a try if you have a switch handy.

You can try a factory reset, then do a basic configuration in Router mode to test if the LAN ports on the GL-AR750S are 1000baseT. If that works, then switch to Access Point mode and test again.

I do not work for and I am not directly associated with GL.iNet

Thanks for your suggestions everyone. I eventually solved it by installing the Realtek drivers for my NIC instead of using the one that came with windows. I’m not sure why, but it works now.