GL-AR750S-ext lose the internet when changing WAN to LAN cable

I’m behind a telco router. I connect to the telco router via wireless.

I have 2 lan ports and wanted to connect a 3rd device. I changed on the main admin panel: cable section: use as LAN

I lose all wireless connections to the telco router.

I change on the main admin panel: cable back from LAN to WAN, then I can connect again to the internet via the telco router.

How do I get the 3 devices/ports for internals and still get my internet connectivity via the wireless?


Are you using repeater connecting to your telco router?

If yes then it should be fine.

But if you feed Internet to AR750s using cable you cannot change wan to lan

Yes, I’m using it as a repeater of the telco router, the internet comes trough 2.4ghz channel 11

No. As soon as I click on the cable section: use as LAN, the internet “dies”, ie no internet connectivity through the AR-750S-ext.


I see. This should be deadly simple and should not be like this. Firmware 3.105?

Current Version    3.105
Compile Time       2020-12-07 15:34:16
Last Update        3.105


Can you pls check if you have Mac clone etc.?

Best way is just to reset the firmware and try

No. No MAC clone configured

Don’t have to. I just set it back to WAN and I get back my wireless internet connection (2.4Ghz).


I just tried.

I can change WAN port as LAN. My repeater disconnect for a while and reconnected.

Just tried.

Yes, it took a while on mine. It took 1minute 35 seconds. I didn’t wait long enough.

Could somebody add that info to the pop up box that ask for the confirmation?

Thank you