GL-AR750S-Ext No cable detected in WAN


I am trying to set up my GL-AR750S-Ext as a normal router. I had previously used it as a WISP repeater without issues. When I try to plug in the ethernet cable from the router to my modem I get the option to choose the protocol. I select DCHP and then I get a message that “there is no cable detected in WAN.” When I unplug the cable, the option to select the protocol disappears until I replug it, so I know it is detecting the cable, but it stops seeing it as soon as I select the protocol (which as I understand it should be DCHP)

Things I have tried:

  • Using a different ethernet cable
  • Using WAN as LAN
  • Rebooting the router
  • Resetting the router to factory default

Any help would be much appreciated!

Does everything work properly if you connect a PC or Mac with an Ethernet cable directly to the modem?

I do not work for and I do not have formal association with GL.iNet

Actually I was an idiot and plugged the router into the modem instead of unplugging the modem power, then plugging in the router, then repowering the modem. When I did that it worked!