GL-AR750S-EXT No Ethernet or WiFi Connection


I have had my GL-AR750S-EXT for a few years and never used it much.

Now, I am trying to use it, but not having much success.

The unit powers on. The power LED is lit, but neither the 2G nor the 5G LED are lit. So, of course, it is not available for a WiFi connection.

When I reset, it does not change this; WiFi is still off. It is possible that when playing around with it when I first got it, that I turned WiFi off in the control panel, but wouldn't reset turn it back on?

Anyway, when I plug it into my laptop with an ethernet cable (and a Belkin USB C to ethernet adapter), it shows up as a network.., but always says "no internet, identifying". It's not connected to the internet, so I am not worried about that.

When I try to go to i can never connect and get the control panel. It just times out.

Once , briefly, I saw that it stopped saying "identifying" and identified the model of the router.

Is this thing bricked?


Do you get an DHCP address if you plug in your laptop?

I assume you mean when I do ipconfig...

i'm not that network savy.

anyway, no; ipconfig does not yield a DHCP address

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::fc92:8970:de1f:96fc%43
Autoconfiguration IPv4 Address. . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

everything below that is related to wifi or BT

That's why you can't access the routers interface.

Since reset did not help, you should try to debrick the device: Debrick via Uboot - GL.iNet Router Docs 4

I think there is a hardware problem...

the thing was sitting for a few minutes, and then when i looked in my networks, the model number was identified for the ethernet connection.., and.., both wifi networks were visible.

then, they all disappeared.

is it still worth doing the debrick?

Ofc. Give it a try. Still better than throwing it away :slight_smile:

probably not fixable...


Something went wrong during updateProbably you have chosen wrong file (too big or too small) or you were trying to update ART on device with unknown FLASH type (and size) which is not allowed. Please, try again or contact with the author of this modification. You can also get more information during update in U-Boot console.

Did you try to update U-Boot as well?

There were two files to download

one was: common upgrade

the other was: UBoot

I chose UBoot - as that's what the instructions said.

I tried twice to do the Uboot - both failed

I did not try the common upgrade file

It's interesting that i can connect to that UBoot web UI.., and bring up the page that asks me to look for the downloaded file, and can then star the upgrade...

so some communication is happening.

Within the debrick manual there is a hint on how to upgrade the uboot version. You should try to do this as well.

if i click on that other button on the uboot GUI.., i just get "the connection was reset"

it won't load a page

tried it a few times

Old AR750S Uboot code will not load anything newer than 3.104 firmware. Unfortunately, GL iNet has removed the 3.104 firmware from their firmware page. Why, I don't know, but at least one user was able to get support to send them the 3.104 img firmware file that worked with their old version of Uboot code. After loading the 3.104 img firmware file, they were able load 3.105->3.216->4.x using the .tar file and the GL iNet GUI.

This post has the link to new uboot code:

After downloading the correct version of Uboot code, you update uboot from this page:

Do not load the wrong Uboot file, or your router will become e-waste.

Note: Uboot is finicky, so try different ports on the router, try different Ethernet adapters. Windows is normally the best OSes to use with Uboot.

1 Like

I don't really understand this suggestion...

i looked for 3.104 img file on those links, bu didn't see anything

The 3.104 firmware image file is only available from support. It is no longer on their site.

i have emailed support


Due to chipset change, 3.104 does not boot on newer batches. So have to take it down.

1 Like

It is nice to know the reason for removing the 3.104 firmware. Those of us with older ar750s units are kind of in a bind, as the update procedure for Uboot does not always work, as the old version of Uboot is very temperamental. Without the new Uboot code installed on an older ar750s, and without the 3.104 firmware, we are stuck without a way to un-brick our routers.

Hopefully you can help @jgf310 save his router, and keep it out of a landfill.

Should upgrade the uboot to latest version and then flash the newer firmware.

Otherwise will stuck in 3.104

Why are you stuck on 3.104?

I have used Uboot and the 3.104 img file to get my ar750s running on 3.104, then used the .tar file and the GUI interface on 3.104 to upgrade to 3.105 with the 3.105.tar file, and then used 3.105 with its GUI and the 3.2x.tar file to upgrade to 3.2x. Multi-step, but I got there.