GL-AR750S-EXT openwrt correct firmware for new router


I purchased end of last month this particular model and would like to update to the last stable openwrt release which I can upload via the web interface>Advanced settings>LuCI

I haven’t installed the latest GL-iNet firmware upgrade (still sitting on the 3.102).

I have done some background reading and there are users experiencing issues with the openwrt firmware upgrade which can be accessed from the official wiki.

Can anyone please link me to the config/tar file that would give me no installation issues?

Thanks in advance. :slight_smile:

1 Like

Install 3.105 first, then 3.203 - here is the link to the firmware pages.

Thanks BUT should I do that since flashing the router with openwrt will overwrite the native settings.

Please correct me if I’m wrong.

If you change to vanilla openwrt firmware, of course you need a clean installation, without keeping the settings.

Is it stable compared to the default firmware? I find it:

  1. Very unstable
  2. Drops wifi constantly
  3. When connection is lost it doesn’t make the two wifi channels available and when it does show one (5G) it tells me that it can’t connect!

If that’s the case, mind pointing at the config file I need to install because right now I’m considering returning the device for a refund. Not happy with the router, unfortunately.

I’m using it in “repeater” mode at public wifi.

Hey, I’m trying to get my GL-AR750S updated to latest OpenWRT currently as well.

So far I had better luck flashing the NOR image. I tried the NAND image and it failed to install, but I only tried it once so it could have been my error… just didn’t have a lot of time so fell back to the NOR image. (The images are from Index of /releases/21.02.1/targets/ath79/nand/)

I haven’t tested anything other than basic functionality yet, but I am posting this message behind the GL-AR750S running the NOR image above.

The downside of the NOR image is that you don’t get access to the 128MB NAND flash on the device out of the box, you have to DIY, which I’m going to attempt to do right after I write this, so I’ll edit this post or post in this thread if I get some results to share.

Thanks for the update and links, glinoob.

So you install these files via the Luci link in advanced settings, right?

Yes that would be great, thank you. Keep me posted with your attempt to update to the 128 NAND flash, which honestly I don’t have a clue of what it really is. I like tech stuff but am
not a geek.

Just to add what I found that worked for this process.

  • I used uboot to load the nor version (the nor-nand) would not load.
  • Then logged in without setting a password at
  • Was then able to use: System > Backup / Flash Firmware & loaded nor-nand
  • I did not retain configuration (unchecked) when loading nor-nand
  • waited for the reboot (power led) and reconnected at
  • System > Administration > Router Password & set a password
    Note that it takes a while for the settings to change and apply (be patient)
1 Like

Thanks for the update…and for the record; hopefully it helps other users.

I myself ended up returning the device after the last OEM firmware uninstalled Luci. I lost patience and gave up.

Have a nice day :slight_smile:

I had to use about the same procedure to get my AR300M to load and boot off the NAND device with OpenWrt 21.02 firmware. OpenWrt 21.02.0 - First Stable Release - #10 by eric

1 Like

Here in my 750S the Nor/Nand works flawless. Uboot the Kernel then do the sys upgrade.

1 Like

I just bought a Spitz and will now have the Slate as a spare, so I’m hoping to give this another go in the next few weeks. If so I will do my best to post the exact steps I took here.