GL-AR750S-EXT Slate Iphone tethering issues

We have a GL-AR750S-EXT Slate set up in our 5th wheel using Visible wireless on an Iphone 6S.

When tethered to the Iphone the internet connection is constantly lost every few minutes or so, makes no difference if tethered or is using wifi to connect to the Slate. I have tried all the obvious things like bigger PSU (3A) cooling with a fan. This is part of the log.

Wed Jul 20 16:08:31 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 16:08:32 2022 user.notice firewall: Reloading firewall due to ifup of tethering (eth1)
Wed Jul 20 16:09:55 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 16:09:55 2022 user.notice firewall: Reloading firewall due to ifup of tethering (eth1)
Wed Jul 20 16:14:12 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 16:14:13 2022 user.notice firewall: Reloading firewall due to ifup of tethering (eth1)
Wed Jul 20 16:21:34 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 16:21:35 2022 user.notice firewall: Reloading firewall due to ifup of tethering (eth1)

Everytime this happens it disconnects from the internet.

The only connection setup that works is to tether the phone to a win10 laptop then connect with wifi hotspot to the slate. I get a very similar log except if never disconnects from the internet and has been rock solid for 12 hours plus. Here is part of that log.

Wed Jul 20 04:33:46 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 04:33:47 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 04:39:46 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 04:39:47 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 04:45:52 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 04:45:53 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 04:51:53 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 04:51:54 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 04:57:51 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 04:57:52 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 05:00:54 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 05:00:55 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)
Wed Jul 20 05:03:59 2022 user.info mwan3rtmon[2896]: Detect rtchange event.
Wed Jul 20 05:04:00 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta)

This works but is very cumbersome, I would like to be able to have the same rock solid internet connection with the Iphone tethered to the Slate. Is there some set parameters that I may have incorrect?

Thanks!!

Does your Visible network permet ping?

Seems that it disable ping and the router cannot detect Internet.

You can also try to disable mwan3 so that the router do not use ping to detect Internet.

hi,

i have the ar750s-ext, visible and a google pixel 4a

never had an issue with usb tethering.

Yes Visible does allow ping, however the latency can be very high, when I tested the ping in diagnostics it failed 9 out of 10 times and when it was successful the latency was 200ms!

I will try to disable mwan3 and see if that helps.

I think android deals with tethering better than ios, what does your log look like?

never needed to look at the log.

let me know how to access the log and i will take a look at it.

I disabled mwan3 in startup, This works well< however after some hours can be as many as 12 and as few as 2 I get this back again and need to manually stop mwan3 again??
Sat Jul 23 21:34:32 2022 user.info mwan3rtmon[2592]: Detect rtchange event.
Sat Jul 23 21:34:32 2022 user.notice firewall: Reloading firewall due to ifup of tethering (eth1)

Try also disabling gl_monitor in Startup because it can also start mwan3.

I do not work for and I am not directly associated with GL.iNet

I tried disabling gl_monitor and rebooting, everything is fine for a few hours then i get the mwan3 event again and a reloading of the firewall. it seems that the only way to prevent this for any length of time is to stop the mwan3 process in the startup menu. This is OK but not a permanent solution. Does anyone have any other ideas?

You can uninstall the mwan3 package.