GL-AR750S Galaxy S10 USB tethering problems

I recently switched from a galaxy s8 to a galaxy S10, but the USB tethering feature doesn’t seem to work properly with the galaxy s10 while previously everything worked perfectly. The s10 shows up as connected in the admin panel, but the internet connection rarely seems to work. When I do have an internet (not wifi) connection, the internet connection seems to shut down rather quickly. For example when I have an internet connection and try to do a speedtest, it works for 1-2 seconds until the speed reaches around 5.3 Mbps and the internet shuts down completely.

For some reason, I also get a samsung dex popup when connecting my phone with the router which previously wasn’t the case when using a galaxy s8.

Note: I am using the exact same setup as with my galaxy s8, have already tried using different usb cables (both OEM and not OEM) and the router power adapter is original. The phone I’m using is a galaxy S10 SM-G973F (european exynos model) and I’m on firmware 3.025.

Just tried firmware version 3.100 (1212) but the same problem persists

What is the system version?

What do you mean specifically with system version? The version of the phone used for tethering, the firmware version of the router …

Oh, I know the router firmware version you mention above. I mean the Android system version. Tks.

I was on android 9 one UI 1.1 with the September security patch level, but just saw there is an update available to android 10 with one UI 2. I’ll also install the update and keep you updated

Hi ahoste,
We haven’t tested Android 10 yet, maybe there are incompatibilities. We will arrange testing and fix as soon as possible.

The same problem persists on android 10, but I just found out if I connect to a VPN on my computer (not on router), I can surf the web normally and the problem goes away. Once I disconnect from the VPN the same problem comes back again.

To clarify more on the problem that is happening, pages keep loading indefinitely or load extremely slowly, however apparently pinging for example or still works for some reason. I have also tried USB tethering using a different sim from another provider but the same problem persist (tethering is allowed with both providers so this shouldn’t have been an issue anyways). A regular mobile hotspot from my phone also works perfectly fine.

Another update: I managed to solve the problem by using easytether instead of the regular built in android usb tethering. It is pretty strange this solved the problem since regular usb tethering works perfectly fine on a galaxy s8 with the same simcard.