GL-AR750s keeps disconnecting

Hello I still have problems with my AR750s Slate.

The problem has been heavily talked about on this forum (just search AR750s disconnect on google) but the issue still persists : I use the AR750s as a router repeating a wifi network on both wired and wireless (the issue stays on both 2.4G or 5G network), and sometimes the wifi connection drops. The local network is still available but it doesn’t see the wifi network for a minute or two, then it reconnects. I’m pretty sure there are no issue in the signal and it’s a problem with the AR750s.

I’m using the latest testing firmware 3.104 and the issue has been present on all the firmwares I’ve tested. I think it’s an hardware issue. What I didn’t try is powering the AR750s with a better power supply (>2A for 5V).

Has anyone still that kind of issue with the AR750s?

Thanks in advance.

@wellnw pls help on this issue.

@o-dnt
Please provide your email address, I will update the firmware of the driver after upgrading .

Nope, wotks pretty well that thing, but it doesn’t seem to be the case for everyone here, I read often just because of the algo the board here uses that ppl have the same problems but it might is fixed now (I didn’t update yet and had never the problem) in the latest release which is either released today or will be released. Hope I could catch you up on where we’re at with this. And I would let power like intended on the same voltage as the original, mine works from computer usb, worse, even from netbook usb power.

Is there a temperature stability problem? I had mine in a cabinet. It wasn’t overly warm and other electronics had no problem. Just for fun, I put the AR750S on the outside of the cabinet and it seems to be more stable. I am going to pull out my infrared thermometer and see what the temps are.

I have the same issues… I am using it as a repeater with my isp and the wifi connection just drops after 5-10 minutes, my gl-ar750 is connected to my computer USB port, also my 5g connection does not connect to the internet once connected to phone or laptop and cannot connect to the webgui I have to connect to 2g then connect to the router I have tried different firmware and I don’t know what to do, I need help, please.

I wrote a small program that pings a remote address. It can keep track of disconnects. It is configurable as far as interval, the name of the log file, the remote ping destination and whether to log all pings or the ones that time out. I wrote it using AutoIT and can provide the source and object code and an ini file that it uses. If anyone is interested, PM me.

I have not had these issues personally when using WiFi repeater extensively for some length of time now.

My signal is excellent however and I’m using a solid power supply.

Perhaps there is some correlation in client devices or the type of AP… maybe you should share the details and see if there is something in common. The SNR level you are dealing with might also be pertinent.

@locomambo
You need to use the power supply of 5V/2A

It doesn’t matter what power supply I use. I know how it behaves with a weak power supply.

What’s your SNR to the upstream network?

What do your system logs say when your ping script fails?

Hello sorry for not answering sooner I managed to solve entirely my problem by installing mainline OpenWRT.

I know it won’t be an answer to everybody still having the issue as it’s quite difficult to install (you need to use u-boot to flash) and you lose the user-friendly interface of gl-inet.

So it’s definitely not a hardware issue but some kind of bug with the gl-inet modified openwrt. Also I noticed that my load average is now much lower than with the gl-inet firmware (it’s now below 0.10 most of the times when it could go up to 13 with the gl-inet firmware).

for installation instructions I used the following links (luci won’t be installed by default) :

thanks guys it actually work, connecting to an ac power source instead of the usb computer port helped my issue…you guys rock