GL-AR750S LAN/ WAN ports not working?


Sorry if this is obvious but when I plug any device into either the WAN/ LAN ports of my GL-AR750S, I am not seeing any activity at all (eg it does not seem to know a cable is connected). I have tried different cables and other devices to isolate the issue to the GL-AR750S. Is there something I need to do to physically enable these ports?

Thank you for your help!

Nope should be enabled by default. Have they worked ever before on your device? Maybe try factory resetting it just to make sure before raising a support request?


Thank you for your reply. No, they have never worked. I just got it the other day. I have tried a factory reset, no change.

Maybe I got a bad unit? It works fine with wifi but for my application, I would like to be wired.

Both WAN and LAN do not work? When you use wifi, do you use WAN as Internet source?

Ethernet seldom has fault. But it can happen.


Correct, it seems that both the lan and wan ports are not functional. I also tried running the wan port in lan mode, no difference.

Using wifi as a client to an existing wifi network and then creating a new ssid from that. I am determining that the ports don’t work by checking the connection status on my computer. No status lights whatsoever.

Thank you!

Have you tried another cable? It’s possible the included cable might be broken.


Yes, I have tried different cables and also tested the cables with another device to make sure they are known to be working. Thanks!

Maybe you can just talk with customer service and get a replacement.

Hello, I have a smiliar problem with my GL-AR750. The cable running through a building from another router plugged to the WAN port is not recognized at all. Surprisingly, when I put a LAN switch between this cable and connect my GL-AR750 t the switch with another cable, it works just fine. Also a computer connected to the LAN switch can reach the network with a decent speed. Since there are other users with a similar issue - the cable in the WAN not bing recognized and since connecting a switch between the GL-AR750 solves the problem I do not think the cable is broken in any way.

Hello, I encountered the same problem. I updated the firmware to version 3.203, I’m using a 4g modem connected trough USB port. I can connect and configure the router using the Ethernet interface (cable is OK), but i can’t connect to internet. When I’m connecting to Wifi the internet is accessible and also the router web interface. It looks like the routing is not working from cable to internet.
Does anybody has a clue?

I am not sure why. But maybe just do a firmware reset and start over.