GL-AR750S no longer starts WIreguard VPN client at startup

After the most recent software update for the GL-AR750S, the Wireguard VPN client no longer runs at startup. With the previous release, it properly loaded at startup, but now I have to manually start it.

Is there a way to make it run at startup again? Or find out what is causing it to not run?

Hi Ingenium,
What is your firmware version?

3.025. When I upgraded in August or September from the previous release, the VPN client stopped running at startup.

Hi Ingenium,
Please try the new testing firmware https://dl.gl-inet.com/firmware/ar750s/testing/openwrt-ar750s-3.100-1126.tar.

I have the same issue with 3.100. When I reboot the router, the VPN client doesn’t start automatically. I have to login and manually start it each time.

Does it matter that I have multiple Wireguard client profiles configured? I would think that it would just re-establish the client profile that was last connected, but maybe that is what’s causing the issue?

I removed the other Wireguard client configs, and the issue persists. In Luci advanced config, the wireguard service is set to start, with priority 99. If I manually run this (/etc/init.d/wireguard start), then the VPN interface correctly comes up. So it seems that it’s not actually getting executed on startup.

Any ideas on what might be wrong? Any way to enable logging to get a better idea for why it’s not running? This is really frustrating because this router is setup at a remote location, and when the power goes out, there is no way to restore the VPN and someone has to physically go there and turn it back on.

Hi
I’m using AR750S and on 3.100 firmware too.

My WG client will restart at every reboot. Must set your “Button Setting” to ‘Wireguard Client Toggle Option’ and the slide switch to ON (Left).

I’ve also have an extra GL-USB150, and using their Goodcloud, I could access AR750S menu remotely.