GL-AR750S Port forwarding + VPN not working

Hi dears, I might be doing something wrong so asking for the specialists help: I have my GL-AR750S working as a replicator of my main Router.
So in my GL-AR750S I have installed a VPN with dedicated IP (I paid extra to have a dedicated IP address) using wireguard. So far so good. So all devices connected to the GL-AR750S are now on the VPN.
However, I need to open a specific UDP port 44158 for one device connected to the GL-AR750S so I went to the GL-AR750S dashboard → Firewall → and added the device there as follows:
Name: Device1
Protocol: UDP
External Zone: WireGuard
External port: 44158
Internal Zone: Lan
Internal IP address: 192.168.8.X (IP of Device1)
Internal Port: 44158

However when I do that and test it with https://www.yougetsignal.com/ for example, it says por 44158 is closed.
I tried to open the port in the VPN website (torguard) as well but still not working.
Any clues what am I doing wrong?
Thanks

When you connect your wireguard client on the router, there is an option “allow access to local network”. Pls make sure that option is ticked.

Thanks buddy. I have just tried that but unfortunately port UDP 44158 still closed :frowning:

First, can you confirm that port 44158 is opened on Device1’s WAN?

Then can you enable both udp and tcp in the port forwarding? If still not, pls let me know.

BTW, pls try 3.211 beta2 https://dl.gl-inet.com/firmware/snapshots/3.211_beta2/ar750s/

Thanks again so here is all I just did:
1- Installed new firmware (no keep previous stuff so new installation)
2- Installed the wireguard again in the Glinet
3- Port forwarded again now using TCP/UDP option.

The “Device1” Is a Helium hotspot that is always “listening” on 44158. I have other hotspots and when conecting directly without vpn I never had an issue opening port 44158, this is the first time this is happening.

Worth to mention that I am paying for a dedicated IP address and the pack is all from TorGuard vpn. Any other ideas? Port 44158 still closed :frowning:
Cheers

Just to add, seems I was able to open the TCP port 44158 however I was not able to open UDP port. Maybe this is related to the wireguard setup on my vpn side?

I think the problem (udp or tcp) is not related to wireguard as it is just a tunnel.

If you Helium use tcp (or udp) you need to port forward tcp (or udp). Can you confirm it works or not?

In this guide How to: mining Helium over a cellular connection ✨ UPDATED ✨ | by Oliver Switzer | Oct, 2021 | Medium

the port forword is on tcp.

I have a read on this, it is a bit different in my case because I am not using a mobile, so I am using my own internet, my own router with one public IP and the Glinet with another public IP that I bought from the vpn server.
For some reason after doing all we discussed above it worked. I guess opening both TCP/UDP at the same time worked (or it was something else we did but it worked!).
Now it shows as port opened somehow. Crazy. Cheers.

2 Likes

Here’s some snaps of my configuration https://imgur.com/a/ReUYenB, which is not working.

If the gl router is behind another router, try portforwarding whatever ports the vpn uses from main router to gl router.

Hi guys, ihave same issue as @rafrox and exactly same situation.
Can you share what have you done to fix it.
Thanks

But he has solved his issue by using exact the solution marked in this thread: open both tcp and udp ports

So,

I am in this same situation and I have both TCP and UDP forwarded. Latestfirmware

I have my home router, then the GL.inet plugged into my home router. The Wire guard is connected with a dedicated IP. I have port 44158 forwarded on TorGuards website for both TCP and UDP.

I am at a loss

Is there a different firmware I should use?

Make sure you port forward on the router from vpn zone to lan. Post screeshot to confirm.

Would like to confirm, my settings were correct. The SD card on my miner was corrupt. I had a hunch, went back to the install site, reflashed the SD card with the latest image and by the time I got home the port was open. No settings changed.

Learn from my experience. Thank you for the quick response alzhao.

1 Like

Hi, can you send me screen of your settings, I’m in the same situation, so maybe I done as you have and it will work. please help me, my router is gl-ar750s and I use surfshark vpn with static ip as you, but still relayed. I think in advanced settings of router should be something which is different for me and you, maybe in the Network-Firewall-General or port forwards page, this two pages screen will be enough I think.
Thank you !!!

Have you also port forward 44158 at your fixed IP VPN website? Apart from all that was explained above I also entered my VPN service (torguard) and port forwarded 44158 on there, otherwise it will not work.

so I need to buy torguard to make it work, can you share me the instruction link where I can see how to port forward in vpn service, or it’s all in the interface?

Yeah torguard is the way to go. Super easy to setup just sign for the vpn service with dedicated IP. On their platform you can easily port forward your dedicated ip. Use my code and you get 50% off. Code is: glinetcode

thanks for help I will