GL-AR750S purely as a wireless-to-wired bridge?

I understand that GL-AR750S has a “repeater” mode, but I don’t want double-NAT nor do I want another physical AP in my flat network.

Is it possible for GL-AR750S to act purely as a wireless-to-wired bridge for one wired host?

(My WLC/AP doesn’t support WDS.)

Pls use extender mode. It will work as bridge.

Thanks… But I don’t believe this does what I requested.
Once in “Extender” mode, two things happen:

  1. wireless network of SSID GL-AR750S-30e is indeed bridged to my router/AP, as long as I set laptop’s WiFi interface to a static IP address (and DNS). Acquisition of IP address by DHCP fails.
  2. wired connection to AR750S’s LAN1 port is still on 10.0.8.0/24 and is NAT’ed to router/AP, just as it is when in Router mode.

However, this isn’t what I need - I need my wired (not wireless) connection via AR650S’s LAN1 port to be bridged to my router/AP.

Also, it would be great if you could explain why DHCP fails for (1).

Didn’t change any other settings?

After you set up extender, pls reconnect all the wired devices so that the get new IP addresses.

Both 1 and 2 should not be a problem.

Did you read what I wrote? I documented actual observations.

I have similar observation.
To put it simply, in extender mode, what we would expect is:
Main Router WiFi --> AR750S --> Wired to Client. and the Client should get the IP from the Main Router DHCP.

But in this case no, in Extender mode, the AR750S still behave like a ROUTER, to add, it does not give any IP address to the client. So what I need to do is to set a static IP on my client to the one within the same subnet as the AR750S IP when it was a router.

@nipoli001 @AlexFer I cannot share your observations.
:arrow_right: I set the network architecture to extender
:arrow_right: Router asked for credentials of my WiFi
:arrow_right: After connection was established it gives a message that you can only access the routers gui if you set the IP manually to the IP range of the router

After that, my notebook had an IP from the IP range of my home network by DHCP.

Just to clarify, did you have the subnet of the Slate in the same range as your home network?

Anyone can make a mistake, so, retried, now, with printouts as evidence.

In summary, both of my observations in previous post are correct (with exception of “LAN1 port is still on 10.0.8.0/24” should be “LAN1 port is still on 192.168.2.0/24” since I changed AR750’s internal LAN prefix).

Implementation:
Border router/WLC/AP is FWF-61e, on 192.168.1.2. It acts as DHCP and DNS Server for internal network. 61e’s " wire_less_ssw" is a logical bridge between internal ethernet switch and WLC.
AR750’s Wired WAN (eth0.2) is 94:83:C4:xx:xx:0E has DHCP reservation on border router for 192.168.1.110
AR750’s Wireless WAN (wlan-sta) is 94:83:C4:xx:xx:0F has DHCP reservation on border router for 192.168.1.109

Before changes, in AR750S’ away from “Router” Network Mode, laptop’s connected to AR750S’ connections:

Connected by wire to LAN1:
$ ipconfig
:
Ethernet adapter built-in’i219-LM:
IPv4 Address. . . . . . . . . . . : 192.168.2.218
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.254

Connected by Wireless, SSID GL-AR750S-30e
$ ipconfig
:
Wireless LAN adapter built-in’8260:
Connection-specific DNS Suffix . : lan
IPv4 Address. . . . . . . . . . . : 192.168.2.238
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.254

Now, changes… Setting AR750S to “Extender” Network mode:

Connect laptop by Wireless to SSID GL-AR750S-30e
$ ipconfig /renew

Windows IP Configuration

No operation can be performed on built-in’i219-LM while it has its media disconnected.
No operation can be performed on Local Area Connection* 2 while it has its media disconnected.

DHCP fails!! Obviously, no connectivity without IP address.

Set laptop’s wireless interface to static IP 192.168.1.199/24.

$ ipconfig
Windows IP Configuration
:
Wireless LAN adapter built-in’8260:
Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 192.168.1.199
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.2

Connectivity to border router and other LAN devices resumes.

In Wireshark, I can see AR750S sending ARPs, spoofing itself with border router (192.168.1.2):
Frame 9: 42 bytes on wire (336 bits), 42 bytes captured (336 bits) on interface \Device\NPF_{43FB9F59-544B-4AAE-B5A6-5A0E4C30749D}, id 0
Interface id: 0 (\Device\NPF_{43FB9F59-544B-4AAE-B5A6-5A0E4C30749D})
Encapsulation type: Ethernet (1)
Arrival Time: Jan 11, 2020 09:43:15.979993000 AUS Eastern Daylight Time
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1578696195.979993000 seconds
[Time delta from previous captured frame: 0.358920000 seconds]
[Time delta from previous displayed frame: 0.358920000 seconds]
[Time since reference or first frame: 2.764617000 seconds]
Frame Number: 9
Frame Length: 42 bytes (336 bits)
Capture Length: 42 bytes (336 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: eth:ethertype:arp]
[Coloring Rule Name: ARP]
[Coloring Rule String: arp]
Ethernet II, Src: GlTechno_01:23:0e (94:83:c4:xx:xx:0e), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Destination: Broadcast (ff:ff:ff:ff:ff:ff)
Source: GlTechno_01:23:0e (94:83:c4:xx:xx:0e)
Type: ARP (0x0806)
Address Resolution Protocol (request)
Hardware type: Ethernet (1)
Protocol type: IPv4 (0x0800)
Hardware size: 6
Protocol size: 4
Opcode: request (1)
Sender MAC address: GlTechno_01:23:0e (94:83:c4:XX:XX:0e)
Sender IP address: 192.168.1.2 (192.168.1.2)
Target MAC address: 00:00:00_00:00:00 (00:00:00:00:00:00)
Target IP address: 192.168.1.110 (192.168.1.110)

(See attachment for more)

On laptop:
$ arp -a

Interface: 192.168.1.199 — 0x6
Internet Address Physical Address Type
192.168.1.2 94-83-c4-xx-xx-0e dynamic

So, as seen from its own wireless network, AR750S’s spoofing itself as border router 192.169.1.2.

On border router:
FWF61E4Q16001082 # get system admin status
username: admin
login local: ssh
login device: wire_less_ssw:192.168.1.2:22
login remote: 192.168.1.109:54442
login vdom: root
login access profile: super_admin
login started: 2020-01-11 10:27:22
current time: 2020-01-11 10:27:56

and

FWF61E4Q16001082 # get system arp
Address Age(min) Hardware Addr Interface
192.168.1.109 0 94:83:c4:x:xx:0f wire_less_ssw

So, AR750S is NAT’ing, even though supposed to be bridging (and spoofing, as seen on its own internal wireless network).

Now… Let’s try wired connection, disconnect from WiFi and connecting laptop to AR750S’ LAN1:

DHCP works!

$ ipconfig
:
Ethernet adapter built-in’i219-LM:
Connection-specific DNS Suffix . : lan
IPv4 Address. . . . . . . . . . . : 192.168.2.218
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.254

Administrative connection to border router is OK, and again, “login remote” is from 192.168.1.109, but this is expected, because it seems wired connection is still operating in routed mode, despite “Network Mode” in GUI being set to “Extender”.

Lots of time wasted documenting above, since, undoubtedly, GL.iNet’s engineers know all that.

The real problem is that GL.iNet hasn’t properly documented function of “Extender” Network Mode, leaving to end-user to speculate.

Can’t help with that.

I can just say I started extender mode and it worked for me without issues.

I don’t know what to do with all the rest of the information you’ve given, because just “proving” it’s not working for you doesn’t add any clue on where to search for the solution.

@ThH did you used wired connection to the Slate in Extender mode?
And to answer your question nope the main network subnet are totally different.

You need to add both interfaces to the BRIDGED network - use the Advanced tab/mode to see what the interfaces are called and where they are. The BRIDGE will get the single NAT DHCP IP Address from upstream, not the individual interfaces.
You will have to flip the wifi client in the bridge from server to client and give the AP credentials.

The extender mode may do this automatically, but I don’t know which ports do what.

Retesting it just now and connected notebook to LAN port. Wireless (master) of the Slate is off.