GL-AR750S Slate VPN won't reconnect (icon yellow)

Hi there,

I have a GL-AR750S and I’m struggling with very occasional loss of connection through my Torguard Wireguard Client. When I lose internet the Slate will not reconnect and the Wireguard client icon remains yellow.

The only way to correct is to purge the configuration and generate a new one.

Any advice would be appreciated.

Best,
Sam

1 Like

I have exactly the same issue. How are you connected to the web? The reason I am asking is that this problem occurs when I am using DHCP but seems to disappear if using PPPoE on my GL.iNet. I am really at a loss as to why it happens but in a way glad that you have also come across this issue and that it is not just me.

If the vpn cannot connect, you should be able to disconnect vpn and just reconnect.

If you have to remove all the config files and set up again, it may mean that the your vpn service provider removed that server.

Hi there,

Thanks so much for the responses. @alzhao I’ve tried reconnecting and it just gets stuck at the connecting phase never achieving connection to the server. The server is a dedicated IP through Torguard – I have tested it using their app on my laptop when having the problem via the router and am still able to get connection that way.

@Almahadeus I am connecting using DHCP behind the main router as you are. I’m unable to switch to PPPoE direct through the fibre unit as my ISP won’t free up a second port for me.

I’m not sure if there is any other way to address the issue?

What is the firmware version of AR750S you are using?

@Leo I’m using 3.105.

But I’ve actually realised the issue. If I disconnect the vpn for longer than a certain time then my provider TorGuard terminates the config – which is why I have to generate a new one. Apparently this is a security measure. So the issue is not router side.

Thanks all for the responses.

Mine just hangs by itself after a day or so (get the yellow notification mark) without me disconnecting it. You are right though in that if it stays disconnected for a good while, then the configuration expires. I am still at a bit of a loss as to why it kicks me out and disconnects in the first place.

I just test it on AR750S 3.105
It connect to Internet via an ethernet cable.
And it running WireGuard Client with TorGuard config, it work.
Then I unplug the ethernet cable, the router is disconnect to the Internet.
Wait several minutes, plug the ethernet cable again.
Wait a moment, the WireGaurd connection rework.

I have 3 of these routers and this is an intermittent problem. Sometimes you can abort and the connect and it works other times it takes hours. I’ve tried rebooting the router, resetting the router, rebooting the PC (I know silly) and the abort/connect hundreds of times.

The ONLY logical answer is this is an AzireVPN connection issue. I’m not sure if its on the server or client (router) side.

If the problem was on the client side then rebooting/resetting would likely resolve it…it doesn’t help.

If the problem was on the server side then switching to azire_u1, us2, us3 would resolve it…it doesn’t help.

I’m 1 hour into my current troubleshooting session and about ready to dump AzireVPN. When it works its great but this issue comes up at least once a month.

I can tracert to the WireGuard VPN server IP address but I can’t tracert to the DNS…sounds like a server side issue that AzireVPN would need to solve.

Tested with >10 Mbps up and down with no other clients connected.

1 Like

If you think it is Azirevpn problem, can you ask them to check?

Maybe remove some limitions for client reconnection.

I was about and found a firmware update. It working fine now but I’ll need to watch it for a month before I’m convinced. I downloaded the new firmware and also new profiles. I can now tracert to the DNS.

1 Like

Ok. Waiting for your further feedback.