GL-AR750S USB Tethering not working on Android MMobiles


I have a Slate running on 3.212 - I’ve tried USB tethering on two Android Phones (PocophoneF1 and Samsung S20 FE).

Neither phone detects a USB device connected and the USB Tethering option is greyed out and not selectable on the phone menu. the Slate also says no USB device is connected. I’ve tried different USB cables and charged the 'phones as well

A very old Moto G4 works and the newer 'phones will USB tether to a PC running Linux.

Any ideas please ?



My Slate GL-AR750S is on Firmware 3.201 and USB Tethering works with my Android Samsung S21+. It is strange that the USB device shows as not connected and the USB Tethering option is greyed out on your smartphone. It should at least show the USB connection is Charging phone only.

USB Tethering also works with my older Asus Zenfone 4 Pro.

I do not work for and I do not have formal association with GL.iNet

Thanks for the reply wcs2228.
I have USB tethering working now - it was the USB cables I had tried cables from the same quality manufacturers - it seems they both have 58k pull up resistors which may be the cause of the problems I experienced.
A lesson to try different brands of cables before posting a problem !