GL-AR750S with Huawei 3372h-607 in stick mode

I’ve got a Huawei 3372h, which I gather works in hostless mode as ‘tethering’. I didn’t too much fancy double NAT-ing so I found a guide here that showed how to flash it into ‘stick’ mode.

Long story short I now have the stick booting up with three serial interfaces, and showing up as a modem on the AR750S. I can send AT commands to it, at least for a while.

The title shows as ‘Test PLMN’, and the ‘dot’ on the front page is orange.

My carrier is Smarty, which runs under three UK.

I have tried this config without much joy. I changed the ttyUSB to USB2, which is what responded to AT commands, and I changed the APN to what Smarty says.

Anyone had any joy getting this to work? I might reflash to hostless if I have no luck.

Not that this helps but I have a couple of similar mifi devices and I just use as a mifi and don’t worry about double Nat but then again I don’t do anything to complicated.

Mifi as 192 168.0.1, gl. Inet router at turned off on the Mifi. I can access both devices seperately if I need to.

Yeah tempting to re-flash this device into hostless mode and ‘tether’ to it.

I thought having it as a straight modem would be simpler, but I was probably mistaken!

OK I’m making some progress. Flashed E3372h-607_Update_21., and now I am getting a green dot on the front page, and the logs show the link is up.

That is in conjunction with the settings shown here:

config interface 'modem_1_1'
        option mode 'preferlte'
        option apn ''
        option dialnum '*99#'
        option proto 'ncm'
        option ifname 'wwan0'
        option device '/dev/ttyUSB0'
        option ipv6 'auto'
        option metric '40'
        option delegate '0'
        option disabled '0'

With my APN and ttyUSB1.

Looking better, but still no upload/download!

EDIT - rebooted the router and it works!