GL-AX1800 does not broadcast its own Wi-Fi network when upstream not connected to internet

Hello, I’m trying out the digital nomad life for a few months, I had some issues with Wi-Fi networks at some of the AirBnBs I’ve booked, so I bought a GL-AX1800 to solve these issues, which has largely been successful. I have it configured in Router mode, with a WLAN upstream internet connection, so it’s in Router / Repeater mode, not Extender mode.

The issue I’m having, is when I move to a new AirBnB, and have to connect the unit to the new host’s Wi-Fi network, the unit doesn’t broadcast a Wi-Fi network of its own (edit for clarity: while the unit isn’t connected to the internet), so I have to connect to it with an Ethernet cable to change the Wi-Fi repeater / upstream network settings to join the new host network. Once the unit is connected to the host’s WLAN network, then it starts broadcasting its own Wi-Fi network.

Is there a setting I can configure, to enable the unit to broadcast its own Wi-Fi network even while the upstream WLAN isn’t connected, so that I can join it from my phone to configure the the Wi-Fi repeater / upstream network settings?

Thanks!

I am living a similar life style using an older GL iNet AR750S router. At least with my current router, and I have also used some other older GL iNet routers, none has had problems sending out WIFI in router mode, before connecting it to the hosts WIFI. I have never needed to use an Ethernet cable to login to the hosts WIFI and enter their WIFI password, and always do it over WIFI. Have you made any changes to the default config of your AX1800?

1 Like

Hey @eric, I hope the lifestyle is treating you well!

I’ve only made a couple basic config changes in the GL web UI, nothing that’s noted to be an issue. Repeating DFS channels is enabled, as the upstream WLAN is often using DFS. I haven’t gone exploring the OpenWrt LuCI interface yet. I’ve had this unit for just over a week so far, so I haven’t gotten around to configuring any of the advanced features yet.

In the wireless settings, I’ve only got 5GHz Wi-Fi enabled, 5GHz Guest and both 2.4GHz networks are disabled.




As I’m using older GL iNet routers, I’m still using the stable 3.2x firmware, which has a different look then the new 4.x code. I would recommend turning on 2.4GHz and see if that works, as it would rule out DFS issues.

Unless you need it, I would stay out of making changes with LuCI, as it is very powerful, and great power comes with great danger :slight_smile:

1 Like

Maybe you can enable WIFI 2.4G and change it to a different SSID from that of wifi 5G?

1 Like

Just to to clarify for people this is a Slate AX GL-AXT1800 and not a Flint GL-AX1800?

Yes, Slate: GL-AXT1800 / Slate AX.

This is my first GL iNet router, and I’m pretty excited about it.

I followed the advice to enable the 2.4 GHz network from the unit, which does broadcast after deleting the upstream WLAN network and rebooting the unit :tada:. Workaround achieved, thank you!!

Something is a little weird with the 5 GHz network though, I’m hoping the root issue can be resolved. Thinking it’s related to DFS, I started playing around with the DFS settings in the web UI. The upstream WLAN is on 5 GHz channel 100, which is a DFS channel.

I disabled Allow Repeat DFS Channels on Repeater Options

The router says it’s not connected to the upstream WLAN, but my phone connected to the upstream WLAN sees the router on the LAN, and can ping it. My laptop is connected to the 2.4 GHz network from the unit, and I have internet access. So the unit is able to join the upstream WLAN on a DFS channel, and route traffic from the downstream 2.4 GHz WLAN to the upstream 5 GHz DFS WLAN, but shows a connection failed error in the UI.

The unit is still not broadcasting its own 5 GHz network, regardless of the Allow DFS Channel setting enabled or disabled on the 5 GHz network settings on the Wireless page.

I logged into LuCI just to get the logs, which show a lot of these events repeated:

Tue Nov 1 12:51:16 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1
Tue Nov 1 12:51:16 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1
Tue Nov 1 12:51:16 2022 daemon.info repeater: (/usr/sbin/repeater:1095) Scan starting…
Tue Nov 1 12:51:16 2022 daemon.info repeater: (/usr/sbin/repeater:1179) wlan-sta0: scan…SFR_35E0_5GHZ
Tue Nov 1 12:51:21 2022 daemon.info repeater: (/usr/sbin/repeater:1220) wlan-sta0: found 4 networks
Tue Nov 1 12:51:21 2022 daemon.info repeater: (/usr/sbin/repeater:1111) scan finished
Tue Nov 1 12:51:22 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1
Tue Nov 1 12:51:22 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1
Tue Nov 1 12:51:24 2022 daemon.info repeater: (/usr/sbin/repeater:608) Switching…
Tue Nov 1 12:51:24 2022 daemon.err repeater: (/usr/sbin/repeater:481) skip bss with dfs channel: SFR_35E0_5GHZ 6C:61:F4:41:35:E5 100
Tue Nov 1 12:51:24 2022 daemon.err repeater: (/usr/sbin/repeater:617) not found matched BSS for ‘SFR_35E0_5GHZ’
Tue Nov 1 12:51:24 2022 daemon.err repeater: (/usr/sbin/repeater:564) not found available network, re-scan in 57 seconds…
Tue Nov 1 12:51:28 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1
Tue Nov 1 12:51:28 2022 daemon.warn hostapd: Failed to check if DFS is required; ret=-1

I tried to edit my original post to add this, but it seems that editing is locked?

  • Device Model
    ** GL-AXT1800 / Slate AX
  • Firmware version
    ** v4.0.3
  • Screenshots
    ** Above
  • Network topology diagram
    ** AirBnB host Wi-Fi router > Slate > Laptop
    ** AirBnB host Wi-Fi router > Phone
  • Problem description
    ** Slate router doesn’t broadcast its 5 GHz Wi-Fi network when not connected to an upstream network, likely due to DFS logic implementation
    ** Slate router UI doesn’t accurately reflect upstream WLAN connectivity status, in either error messages or not
    ** Deleting a wireless network from the Internet > Repeater > Join WLAN menu does not prevent the unit from connecting to the wireless network after a reboot

I thought I’d try connecting the unit to the upstream 2.4 GHz network to see if that shows any different behaviour, but haven’t gotten that far yet, and found

** Slate router UI doesn’t accurately reflect upstream WLAN connectivity status, in either error messages or not
** Deleting a wireless network from the Internet > Repeater > Join WLAN menu does not prevent the unit from connecting to the wireless network after a reboot

So I’ve added them to the problem description above. Screenshots below.

I deleted the upstream 5 GHz network, then rebooted the unit. I see Repeater (STA) is disabled, but, the unit is still connected to the upstream 5 GHz network, and is still not broadcasting its own 5 GHz network.

My laptop is connected to the unit’s 2.4 GHz network, and still has internet access through the unit.


I have now connected the unit to the 2.4 GHz upstream WLAN network, and the unit is now broadcasting the 5 GHz network.

Network scan

Allow DFS on the unit’s 5 GHz network doesn’t stick, I can switch it on, save it, then refresh the page, and it reverts to off. I would expect an error message if there’s an error condition.

Okay, so I’ve deleted both the 5 GHz and 2.4 GHz upstream WLAN networks from the Repeater settings, switched the Repeater back to 5 GHz band, but Allow Switching To Other Saved Networks is disabled, and somehow the unit is still connecting back to the upstream WLAN 5 GHz network that I told it to forget. Yikes.

So this unit will be broadcasting all WLAN BSSIDs it’s connected to, when searching for networks everywhere I go? Yikes.

I have been connecting to these networks with Lock BSSID enabled, so maybe the unit isn’t deleting the BSSIDs when I tell it to delete a network?

The best setup should be:

  1. Use the same SSID for both 2.4G and 5G so that when one radio is affected, you still can connect to the router using the same SSID.
  2. Avoid DFS, unless you have to use that
  3. Upgrade the firmware. I think there is update in DFS part from 4.0.3 to 4.1

Thank you @alzhao!

  1. Same SSID for both bands: Noted, but this is the scenario I’m trying to avoid. Many apartments that I’ve stayed in have lots of congestion and noise in the 2.4 GHz band, so I’d like to specifically keep all my connections in the 5 GHz band. I haven’t found a way to force my M1 MacBook Pro to only connect to a 5 GHz network when the 2.4 GHz network has the same SSID, and the 5 GHz RSSI is weaker than -68 dBm, which was often the case and is what lead me to buy the unit. Although it looks like Apple devices using Wi-Fi 6E will need the SSIDs to match across bands: Use Wi-Fi 6E networks with Apple devices :man_facepalming:. Really, I could have bought a USB-C Wi-Fi adapter that let me disable the 2.4 GHz band, but this unit offers much more functionality that I’d like to start using.

  2. Avoid DFS: Bummer, as DFS is a great concept, and most of my AirBnB hosts’ Wi-Fi networks use DFS, so I’m stuck with it.

  3. Upgrade firmware: I’m looking forward to the DFS fix in 4.1!
    4.0.3 is shown as the latest from the unit, and I don’t see a button to trigger the check for update, I assume it happens on page load?

Local upgrade could use a link to the download page.

Googled it and found this page, where 4.1.0 is still listed as beta; while I’m travelling and depending on the unit, I’m not sure I want to take the risk of installing a beta build. I haven’t yet found a link to a build status page to show if the beta build is passing tests.

Seems related, may be different symptoms of the same root cause?
AXT1800’s 5GHz SSID disappears as soon as device is repeating another 5GHz signal - Beta Testing - GL.iNet (gl-inet.com)