GL-AX1800 (Flint) VLAN tagged on port

Hi

I have added VLAN900 to my Flint via Luci interface and wanted to tag this VLAN on port 4 of the router but I can’t do as this version of OpenWrt does not allow modification of the switch section in web GUI.

Can someone please advise how to do this from the command line through the SSH?

Below is my current configuration.

root@GL-AX1800:~# cat /etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘xx04:xx00:xx41::/48’

config switch
option name ‘switch0’
option enable_vlan ‘1’

config interface ‘lan’
option ifname ‘eth1 eth2 eth3 eth4’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option multicast_querier ‘0’
option igmp_snooping ‘0’
option hostname ‘GL-AX1800-d40’
option ipaddr ‘192.168.8.1’
option ieee1905managed ‘1’

config interface ‘wan’
option hostname ‘GL-AX1800-d40’
option metric ‘10’
option proto ‘pppoe’
option username ‘my_username@isp.net’
option password ‘my_isp_password’
option disabled ‘0’
option _orig_ifname ‘eth0.900’
option _orig_bridge ‘false’
option ifname ‘eth0’
option ipv6 ‘0’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’
option disabled ‘1’

config interface ‘guest’
option ifname ‘guest’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.9.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’

config interface ‘VLAN900’
option proto ‘static’
option ifname ‘eth0.900’
option ipaddr ‘10.168.8.1’
option netmask ‘255.255.255.0’

Does this work for your setup, VLAN configuration WAN port (GL-AX1800 Flint) - #3 by hansome
I don’t think think use pppoe and static proto work at the same time.
Only keep,

config interface ‘wan’
option hostname ‘GL-AX1800-d40’
option metric ‘10’
option proto ‘pppoe’
option username ‘my_username@isp.net’
option password ‘my_isp_password’
option disabled ‘0’
option ifname ‘eth0.900’
option ipv6 ‘0’

and VLAN900 should be removed.

Hi @hansome

I have removed VLAN900 from WAN interface config (must have added it there by accident).

I still can’t get my head around it how to add VLAN900 to Port 4 of the router only :frowning:

Actually port4 is eth4 and is LAN. And you mean eth0 and wan, right?
Could your copy another router’s /etc/config/network that works.
I can try at my side.

Here is what I want to do - tag Port 4 of the router (eth4) with VLAN900.
I do not have any other router working with this setup.

You can try this setup:


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:4d29:e070::/48'

config switch
        option name 'switch0'

config interface 'lan'
        option ifname 'eth1 eth2 eth3'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multicast_querier '0'
        option igmp_snooping '0'
        option hostname 'GL-AX1800-427'
        option ipaddr '192.168.8.1'
        option ieee1905managed '1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option hostname 'GL-AX1800-427'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option disabled '1'

config interface 'guest'
        option ifname 'guest eth4.900'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Put port 4 vlan 900 to guest network.