GL AX1800 FW 4.5.16 -- unable to convert LAN1 for a second ISP WAN port

I bought the GL AX1800 (FLINT) router because its firmware is based on an OpenWrt software stack. I upgraded the factory firmware (4.4.6) to the latest (4.5.16) (GL.iNet download center)

As you may know, the open source OpenWrt firmware (openwrt.org) allows the users to configure the Ethernet (LAN) ports in whichever way they want. I have repurposed older Netgear routers (OpenWrt supported) to create an SOHO gateway to connect to two separate ISPs; ISP1 over the "WAN" port and ISP2 over the "LAN1" port and have the remaining LAN ports connected to the private network (192.168.1.0/24).

I expected to do the same with the Gl.inet firmware.

However, the GL AX1800 Web UI does not have any provisioning to convert one of the LAN ports to a second WAN port (for a second ISP).

If you go to the OpenWrt Luci interface, you can install the "mwan3" package and go through the configurations to enable a second WAN connection over LAN1.

But ... the changes you make are not preserved. Upon "reboot" all the mwan3 changes are gone!
Looking at the config files in /etc/config/mwan3 you see the second wan interface are overwritten with what comes "standard" with the device.

Please share the details if you have successfully converted LAN1 to connect to a second ISP

I think you should go to Luci->network->Interfaces to configure.

The following is done in firmware v4.6.0 beta.

First, go to luci->network->Interface->Device and remove eth1 from br-lan

Next, create a new interface, input WAN1, DHCP client, and choose eth1 as device.

In WAN1->Firewall Settings, add it to wan zone.

Finally save and apply all settings.

1 Like

Thank you so much for the detailed instructions on configuring the physical network devices.

I am intimately familiar with the Luci sequence you have outlined in the response.
Before posting my message, I had already gone through those steps to create a "wanb" interface out of the physical LAN1 port.

However, using the Luci > mwan3 Web UI, all the "WANB" interfaces and members (/etc/config/mwan3), are overwritten when the device is rebooted!

Thus, I could not deploy the router at my place of worship, where we have a cable internet (500/35) as primary (WAN) and an ATT LTE modem with an Ethernet port (secondary) to connect to another LAN port (WANB).

I have a couple of other GL.Inet travel routers and I love those products.

For the GL AX 1800 (Flint), I love the fact that product engineering thought of "Tethering" and "USB LTE/5G" interfaces to handle a fail-over scenario.

However, I am disappointed that GL.inet engineering did not envision a use case whereby two or more ISPs (modems with Ethernet media converters) can be connected to the router, to handle load-balancing/failover. Especially given that the open source OpenWRT mwan3 package is capable of this already. I spent about 2:30 hours, experimenting with options in the config files in /etc/config, before realizing, no matter I changed it would be overwritten at device reboot.

I am glad to read that GL.Inet is addressing this in the 4.6.x firmware.

Is 4.6.0 beta stable enough to deploy in production? I would appreciate your candid reply before I spend any more time with it. Thank you.

Hello, version 4.5 and above no longer use mwan3, but kmwan, which are incompatible. When using kmwan, you should do the following:

  1. Change one of the LAN ports to a WAN port in the luci interface
  2. Add the information of your newly created WAN port to the configuration of /etc/config/kmwan
  3. Use /etc/init.d/kmwan restart to restart the kmwan service

Give a configuration as follows:

  1. Change the eth1 port from a LAN port to a WAN port and name it wan2. At this time, the interface will be generated in /etc/config/network.
    image

  2. Add the information of the interface in /etc/config/kmwan

config member 'wan2'
        option interface 'wan2'
        option weight '1' #Interface weight, effective in load balancing mode
        option track_mode 'force'
        option addr_type '4'
        option disabled '0'
        option check '1'
        list tracks 'ping,1.1.1.1'
        list tracks 'ping,8.8.8.8'
        list tracks 'ping,208.67.222.222'
        list tracks 'ping,208.67.220.220'
        option metric '1' #The interface priority is different from the priority of other interfaces
  1. Restart kmwan
/etc/init.d/kmwan restart

After you have done this, the multi-wan page will display the new WAN port information.

4.If you want to use mwan3, you need to disable kmwan. In this case, the network status information provided by the page will be inaccurate.
The command to disable kmwan is as follows:

uci set kmwan.global.enable=0
uci commit kmwan
/etc/init.d/kmwan stop

@_zhang -- thanks for the detailed instructions :pray:t5:
Following the above steps I was able to configure Ethernet LAN1 port for WAN2 (second ISP)
Note: I ungraded the factory installed firmware v4.4.6 to the latest stable v4.5.16.

Suggestion for future firmware release -- it would be awesome if the Web UI can show the associated "device" for all the WAN interfaces in the MWAN UI. For example the first Ethernet shows WAN, the second Ethernet shows LAN1 etc.

I think we have resolved your issue.

It should not worth zero star on Amazon. Appreciated that you can revise that.

1 Like

I have updated my review on Amazon but it may not be visible as it is awaiting moderator approval.

IMO, the official GL.Inet MWAN Web UI is buggy; it is missing the functionality for multi ISP connections , using the LAN ports Whereas it includes entries for "Repeater, and "Tethering"as fail-over WAN interfaces.

Besides, when I read the 4.x MWAN doc, I did not see the above solution mentioned. Had it been there, I would have saved a couple of hours of setup time and deployed it much quicker.

Please treat this as constructive feedback to improve your product.

Thanks again for sharing the detailed procedure in this thread ()

That problem was that Multiple Ethernet WAN connection was not available on this model yet.