GL-AX1800 VLAN on LAN Ports

I bought this router and am now trying to set up a VLAN on LAN port 3 or 4.
I try to config the etc/config/network file like this:

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘10’
option vid ‘10’
option ports ‘0t 4t 5’

Then i reboot the Router but on the LAN Port i get no VLAN.
What I also configure. I can’t get a VLAN on a port.
My Wish:
Port 3 untagged as LAN port (192.168.8.x) and
Port 3 tagged VLAN ID10 as Gest network (192.168.9.x) would be optimal.

Hope someone can explain the solution to me.
Sorry for my English … its bad
Greetings from Germany

GL-1800 Flint
Luci installed


vlan is currently not fully supported in flint atleast not from the luci ui via switch tab.

But I managed to get it working, if you go to the lan interface in luci and click on edit and then go to physical settings then uncheck the eth interface you want to use for the vlan, for example port 3 is eth3.

Now what I have done is just creating a static interface to it, the interface has to be bridged with eth3 with a different ip subnet and firewall zone which forwards to wan and wireguard, I believe its also possible to have vlan ids, then you need to put a bridge to eth3.100 (100 is id) and maybe eth3 itself aswell as physical setting in your interface.

This for me works great.

1 Like

Hey xize11,
I was close to a solution but with your explanation I have now completely understood it.
Now this works great for me too.