GL-AX1800 won't start and won't reset


Today I received my AX1800 from Amazon Germany and I was really hyped!
Unfortunately, after the first start and updating, I relocated it to a better position. I plugged it in and waited for it to start. after 20 min neither the WiFi showed up, nor was I able to connect to it via LAN, also it does not show up in my main router. I then tried to reset it, but the light does not start flashing, it just stays on. I tried it at least 20 times. I also tried to reflash it via Uboot, but there is also the same problem, it won’t show up as if it was off (even though the light is on).

Do you have any ideas?


If the LED is alway blue, it seems it does not boot.

After boot, the LED should flash blue or solidy white.

Can I ask which firmware you flash using uboot?

The problem is, I can’t get it into uboot. Tried every LAN port, none is working.

Hmm I had something smilliar happening at my very first installment I believe this was on fw 3.206 but not 100% sure.

I only received lan when the wan port was connected.

Have you tried this?

Only connect one cable to AX1800. Don’t connect more than one cable.
Hold the reset while powering on. Wait for the blue light flashes 5 times then turns white and stay on.
Release the finger
Manual set the IP address of your connected pc to

Can you make sure the above process is correct?

Yeah, I did just that but it keeps unresponsive. I sent it back to Amazon and waiting for a replacement now.