GL-AXT1800 4.1.0 - OpenVPN server - local LAN not accessible

I have set up OpenVPN server with the standard settings, and Client-to-Client Option enabled.

I can connect to the server with the generated client config file. The traffic is router trough the VPN server which is fine. However, the devices on the local network are not accessible (and visible).

Client to Client option does not seem to work. As well the option “Allow access to local network” in the server settings is gone in firmware version 4.x?! Access to local network worked on firmware 3.x.

What to do to enable the visibility and access to local resources when connected to the OpenVPN server? This is a crucial feature and without it, there is no point to use the server at all!

It has been modified into the VPN Dashboard, please refer to VPN Dashboard - OpenVPN Server Options.

Maybe you mean this option.

It allows that you still be able to access the local WAN network when connected to a VPN server.

This option is checked as well on my side, and has no effect on accessing the local LAN devices.

Can you draw a diagram to clarify how do you want to which subnet.

the router is directrly connected to WAN with DHCP.
The internal network is:

  • Router IP Address
  • Start IP Address
  • End IP Address

OpenVPN server:
Tunnel Address:

I want to access a device with IP

in the Vpn dashboard:
OpenVPN Server Options:

  • Allow Remote Access LAN is enabled
  • IP Masquerading is enabled (disabling - no effect)

What kind of device is at IP address (Windows PC, Mac, NAS, etc)? What protocol do you want to access it (SMB, http, ftp, etc.)? Are you able to ping the

In terms of visibility, LAN devices would not be able to broadcast across subnets and need to be accessed by IP address.

I do not work for and I do not have formal association with GL.iNet

If you want to access the LAN network ( network from the vpn client, this should be the only option needed, supposing you are using ovpn client on your pc/smartphone directly.

Pls check @wcs2228’s questions.

I appears it was Windows firewall problem on the device. This topic helped

Consider this topic closed and I am sorry for wasting your time. It is not a router problem!

1 Like

That was what I suspected (applies to both OpenVPN and WireGuard):