GL AXT1800 4G Tethering not working

Im still struggling to get a huawei E8372h-320 (carrier locked) & a Huawei E8372h-608 (unlocked) working with the GL AXT1800. Both dongles work in a Beryl, Brume, Mango & a windows PC.

The blue lights on the Huawei dongles light up as if it’s connected, the admin panel of the router shows it’s connected “tethering” however there is no internet.

‘lsusb’ shows the huawei device is connected - Bus 001 Device 008: ID 12d1:14db HUAWEI_MOBILE HUAWEI_MOBILE

Kernel log shows;
[ 1495.174891] cdc_ether 1-1:1.0 eth3: register ‘cdc_ether’ at, CDC Ethernet Device
[ 1495.176431] cdc_ether 1-1:1.0 eth3: kevent 12 may have been dropped
[ 1495.184906] cdc_ether 1-1:1.0 eth3: kevent 11 may have been dropped

not sure why it wont connect

@dengxinfa Pls help to confirm this issue.


I only recently got my first gl.inet router (also a gl-axt1800) and today I got a Huawei E8372H-320 to try and use with it for an upcoming trip.

I also seem to be struggling to get it working. I’m able to tether it successfully as ‘eth03’, but also getting no Internet.

Because I’m a dummy, is anyone able to point me in the direction of some standard setup/troubleshooting steps?

The Huawei Internet connection is working fine if connect directly to it via Wifi. I can see incoming/outgoing data on the eth03 interface in the Luci web interface, and while I don’t think it was an issue, I tried updating the IP of the gl.inet router to just in case it was conflicting with the Huawei USB modem.

Any advice appreciated! Thanks.

Ok - so I just did a factory reset on my gl-axt1800.

Then I logged into the Huawei E8372H-320 web interface (for the first time) and did basic setup steps like assign a new admin password. I didn’t think this was going to help before, as the Internet connection was already working when I connected directly to the device via Wifi.

Then after logging back into the gl-axt1800 and tethering to the Huawei USB, the Internet connection started working immediately.

Not quite sure what actually fixed it, but perhaps just logging in to the Huawei device web portal and doing an initial ‘setup’.

Just tried everything you did, but still no luck, what’s weird is both my huawei devices work in a mango, a beryl, a brume & a pc. The admin panel of the axt 1800 shows tethering, but there’s no internet connection.

Yeah, it is strange.

After playing around with it more, a couple of times the issue (same as yours) occurred again. I was able to resolve it by unplugging the Huawei USB from the router, plugging it in again and re-tethering.

I’m guessing you’ve tried that, though.

Have you done a factory reset on the Huawei USBs?

yes i’ve tried resetting both the huawei and the axt1800 multiple times, my current solution is to plug the huawei 8372 into a brume and plug the brume ethernet lan into the axt1800 wan. Bit of a PITA as i wanted to take as little as possible to travel with, but at least it works for now, it would be good if the issue was sorted in a fw update.