GL-AXT1800 as WG Client DDNS Remote Access to Admin Panel

I have two GL-AXT1800 devices setup as WG server and client. I can’t access the WG Client device admin panel remotely when the WG VPN client is enabled.

Device A (GL-AXT1800): Setup at home network as WG VPN Server.
Device B (GL-AXT1800): Setup at travel/remote network as WG VPN Client.

DDNS with HTTPS access is enabled on both devices. I’ve setup port forwarding on both of the modems associated with device A and device B.

When WG VPN is disabled, I can successfully access both devices from an external network using their addresses.

When WG VPN is enabled, I can only access the WG Server (Device A). When I enter the DDNS for the WG Client (Device B), I get an error. I experimented with various settings. After enabling the option “Services from GL.iNet Use VPN”, I get routed to the admin panel of the Device A when I enter the DDNS of Device B. I thought this may have something to do with needing an additional port forwarding rule on Device A but I don’t know how to setup it up correctly.

What is the firmware version of your device?

In this case, you are using DDNS Test on device B. What does it display?

This is normal. the principle of DDNS is that the device reports its public IP to the DNS server. when it uses VPN, it reports the public IP of the VPN server, so the domain is also used to access the VPN server.

A ‘this site cannot be reached’ error. Like it’s an invalid link

Is there a way to get around this and make it reach into the client’s admin panel?

My mean is use DDNS Test Button in page.

You should disabled “Services from GL.iNet Use VPN”.

Thank you for clarifying. I disabled “Services from GL.iNet Use VPN” and run a DDNS test on Device B:

The WG Server device exhibits a similar result by the way. It displays the same public ISP IP in the DDNS domain resolution, and in the Interface IP it displays the local/internal IP assigned by the modem at that location. But for this device remote access has works successfully regardless of whether VPN is running or not.

Did you notice the tip at the top of the dialog? Obviously you need to set up port forwarding on the ISP router of device B.

Yeah, I set port forwarding on the ISP modem connected to Device B, and DDNS works only when I’m running Device B like a regular router/repeater. When I enable WireGuard Client on Device B, it breaks the DDNS functionality. Please let me know if you have other suggestions.

Is “IP from DDNS Domain Resolution” still the IP of Device A when you disabled “Services from GL.iNet Use VPN”?
What is your firmware version?

Is “IP from DDNS Domain Resolution” still the IP of Device A when you disabled “Services from GL.iNet Use VPN”?

What is your firmware version?
It’s the same version on both the server and client, version 4.2.1 release 4

Sorry for the late response. Thank you again for your repeated attempts to help. I tried several ways to troubleshoot this and I wasn’t able to find a fix, so I’ll live with it as is. There are limited scenarios where I need to have remote access to the WG client, so hopefully this won’t be too big of a problem.