GL-AXT1800 can't connect to WiFi as Repeater

Hey guys,

I have recently purchased Slate GL-AXT1800 from Amazon, unfortunately having some issues connecting it to my Home WiFi network.

I have connected LAN1 interface directly to my PC’s NIC and can access the device using IP, unfortunately, when I’m trying to connect it to my Home WiFi in Repeater mode, it can not even see my broadcasted 5GHz SSID, which is definitely working as my iPhone and work laptop is connected to it. When I try to connect it to my 2.4 GHz SSID, it does see it, but it stuck on “Getting” IP address.

Is there anything I’m missing here or I got a faulty unit?

I have tried to reset to factory defaults, unfortunately still the same.

What is the WiFi channel of your 5G wifi?
Where did you buy this AXT1800?

Seems like a DFS issue. Pls make sure your AXT1800 is updated to the latest firmware.

For 2.4G issue, can you get the log after the connection failed?

Thanks Alzhao

Device was purchased via Amazon UK.

I did the firmware upgrade and it seems to be working fine now with 2.4GHz and 5GHz home network, unfortunately still can not see the SSID broadcasted from my iPhone when in HotSpot mode - any ideas?

Can you let me know what is your firmware version?

It’s 4.5.16 release2

Send you a message. Pls check.

It turned out it was “Maximise Compatibility” option in my iPhone hotspot settings…

With that being switched on, it works perfectly.

1 Like