[GL-AXT1800] Connected device shown as offline since v4.4.5

Yesterday I upgraded the firmware to version 4.4.5.
Since then, two network wifi devices that are in fact connected do not appear in the client list (they are listed under Offline Clients).

The LAN and internet connection of this device is without any problems. In Luci the devices are correctly displayed as online on the status page under “Active DHCP Leases”.

The problem has only appeared since the firmware update.

You could clear the offline list in the GL.iNet UI, see if that changes stuff and try a restart.

Thanks for your hint.
I tried it and found out that actually the problem is the “Block WAN” switch in the client list. If the switch is on, the device disappears from the online list (although its correctly still connected to LAN).

hi, joe-trocken
please execute command (cat /etc/config/gl_block) to check if your wifi devices are in it;If so,please execute (rm /etc/config/gl_block) to remove this file and restart your device for version 4.4.5 no longer uses this file.We will fix this problem soon.

I looked for the gl_block file. They were three MAC adresses. I delete the file and rebooted the router, but the problem still exists.

Please execute the following command to check if there are other configurations for your wifi devices.
cd /etc/config
grep -nr “xx:xx:xx:xx:xx:xx” ./
grep -nr “xxxxxxxxxxxx” ./
replace xxxxxxxxxxxx with your device MAC address.Thanks!

This is the result:

root@GL-AXT1800:~# cd /etc/config
root@GL-AXT1800:/etc/config# grep -nr "A8:E7:7D:2C:BF:8E" ./
./dhcp:51:	option mac 'A8:E7:7D:2C:BF:8E'
./gl-client:103:	option mac 'A8:E7:7D:2C:BF:8E'
root@GL-AXT1800:/etc/config# grep -nr "10:5B:AD:1D:B2:7C" ./
./gl-client:99:	option mac '10:5B:AD:1D:B2:7C'

I ran into another issue: Since the FW update my AdGuard Home doesn’t work after switching it off and on again.
Now I downgraded to v.4.2.3 so the problems are solved.

4.4.5 is a scuffed pseudo stable release which had zero alpha testing so it barely even functions

1 Like