GL-AXT1800 latest firmware Luci language


I updated my GL-AXT1800 last night and found out the Luci page is default using the Chinese language. Did the developer forget to include English language packs in the firmware?

Firmware version: 4.0.1
Release: release3

Stan Wong

The English is the default.

However, if you use a system that use Chinese by default, it may choose that.

I have Chrome and it always choose Chinese.

However if I use incognito mode it choose English.

I tried Edge and Firefox and always choose English.

Attached is my luci page. I can only choose Chinese :frowning:

Auto should be English.

Do you have Chinese in your browser?

I’m using Android Chrome. My system default language is English.

Or Do you read Chinese, actually?

I tried it on English only operating system (Ubuntu), the chrome still show Chinese language.

My Chrome settings has Chinese. Luci display Chinese.

After I remote the Chinese language, luci display in English.

Weird, I don’t have chinese language on my Ubuntu or Chrome. But it still showing Chinese language. My firmware version is 4.0.1 release3.

In my experience, the best way to make sure you’re in English UI is to make sure you’ve installed “luci-i18n-base-en” package and force choosing English in Luci to switch over or the “Chinese-UI” will be haunting you. :sweat_smile:

1 Like

Very strange design.

I installed the luci-i18n-base-en packages and seems working OK.

Let me check whether the luci-i18n-base-en is installed on the latest firmware. The previous firmware is in English by default.

Thank you for the tips!

luci-i18n-base-en is not installed by default. Issue resolved after install the package :smiley:

Thank you!


This worked for me too.