GL-AXT1800 Samba Write error after several time

I'm using GL-AXT1800 router which is newly bought. My old router GL-AR750 is working great for internet and file storage but a bit slow.

I'm using Samba for file sharing and it works fine and fast. (as shown)

But after several time (randomly), usually after read/write of files heavily, Windows tells me unable to write file to server. I need to reboot my router and it resume to normal. I have tried to restart samba service but it can't help.

I would like to someone's help on this issue to solve this problem. Anyone meets this problem or similar error as mine. I'm thinking it is caused by the TF card error and I'm trying to backup and chkdsk to the card.

Thank you.

You can use ext4 instead of exfat.


I would even say: You should use ext4 instead of exfat.
Maybe this should be updated in the docs and the GUI as well... exfat fails nearly every time people trying to enable network storage and use it with more than just a few files.

1 Like

The reason is EXT4 is not user friendly to Windows user but I could try tomorrow.

Thanks for your both and advice.

I tried some files with space or non alphabet characters in file names are unable to be copied through samba. Is it issue of openwrt or samba4?? Thanks.

Mostly an issue of exfat ...

1 Like

Thanks and the problem is solved and it is working great for over a week. Cooy & paste are much faster than my old router AR-750. :blush:

1 Like