GL-AXT1800 (Slate AX) Repeater Connection Issues

Good afternoon,

I am writing because I am having trouble with the repeater functions of the unit. At home testing connecting to our home wifi, there was no problem. However, now I am at the hotel, and it won’t work. I can see the hotel wifi I want to repeat. I connect to it, but the connection never completes. If I connect directly to the hotel wifi with my laptop, it works; after, an internet window popup asks for the room number and name. I am not getting this popup when trying to log in with the repeater, and I suspect this is the problem. How can I get it logged in correctly? How can the repeater see this popup login information? I would really like to get this working correctly. Thanks for your help, and have a nice day.


Are you on the latest firmware? Connecting was a mess for me on some of the original builds - enough that I junked the Gl.iNet builds and went to a more stock ish OpenWRT. Supposedly things have improved, but I haven’t found a reason to go back.

Thanks for your fast reply!

Honestly, I don’t know. It showed up from Amazon a few days before the trip. I did the basic setup, tested joining our home network, and set up a VPN. After that, it got packed and isn’t working at the other end. I am doing tech support for my wife, who has the unit out of town.

It will try to join the network. Sometimes it times out, and one time it thought it was connected, but a device connected to the repeater does not have internet. So it seems there needs to be a way to log in to the hotel system after connecting. Any ideas on how to do this?

I have the same unit and have never had this happen to add to our frustration. If it isn’t a simple fix, she will return it; not worth her effort or frustration if the device doesn’t work as sold.


Try authenticating directly with your laptop and then cloning the laptop’s MAC address to the router.
Connect to a Hotspot with Captive Portal - GL.iNet Docs (

Connect end device to Slate AX
Turn off any VPN
Connect Slate AX to source WiFi
Point browser on end device to

Does that work?

Thanks for the help. Turning off the VPN allowed the connection to work. She got the hotel popup and everything is working now.

Thank you.