GL-AXT1800 Tailscale update

My bad, I forgot some command. I updated the command block in my previous answer.

2 Likes

…removed…
this may have included personal id / info

Thank You for sticking with me… this works…

image

1 Like

Thanks for your input. I updated the main script to support the AXT1800 as well.

1 Like

Sorry if this has been answered previously. I have an 1800 slate ax. Running Tailscale seems to work until I try and use a custom exit node. No traffic seems to pass. If tried altering the local DNS as mentioned in an older post, but it didn’t help. I’m running the latest beta 4.5 jan 24.

Has anyone made this work?

I don’t see why this workaround wouldn’t still work but I don’t use Tailscale:

Thank you. But i don’t want to use the router as an exit node. (Not yet anyway) I just want to connect to an exit node and have all my traffic route through it.

I know the exit nodes work as I can use them from regular tailscale clients.

1 Like

This fixed it for me. I noticed the router could ping through the exit node but nothing on the lan side of the axt1800 could. Added the firewall zone as described and suddenly the lan side could route all traffic via the exit node. Obvs something gl inet need to fix.

https://forum.openwrt.org/t/help-to-configure-tailscale-as-a-proxy-service/142428/2

Thank you admon! Just used the manual commands here to update tailscale on my GL-AXT1800. Tried to use your script but, as I suspected, not enough space. So, did the commands manually here and I’m now running the latest version of tailscale which as of 2/20/24 is 1.60.0.

I really appreciate your contribution! This is a really capable travel router made even better!

1 Like

You could use my script with --ignore-free-space :wink:

Manual mode worked for me - thanks!

1 Like

Any update on this? The 1.32.2 version that ships with the 4.5.0 firmware has a security issue, so it would be good to get this fixed.

Did you try to update using my script?

Hi! Thanks for sharing that script! I haven’t tried it yet—ideally the official supported version would be updated since there have been some mentions of (unspecified) incompatibilities/problems in the shipping version.

But maybe it works fine? (There is a similar trivial unofficial workaround for enabling Tailscale’s exit node functionality that had also proved torrent in practice, despite it not being official: https://forum.gl-inet.com/t/brume-2-as-a-tailscale-exit-node/27663.)

@admon I ended up trying your script, and it seems to work, although /etc/init.d/tailscale restart does produce a whole lot of output that looks like errors, see `/etc/init.d/tailscale restart` output on GL-MT2500 · GitHub. Thanks again for putting that together. Maybe we’ll get an official fix for this…

We plan to upgrade tailscale to 1.58 in the 4.5 fixed version.

3 Likes

Hi, i have 4.5 firmware but tailscale is still at 1.32.2 is this correct or should tailscale have updated as you said?

I was referring to one of the fix firmware versions, such as 4.5.16 for Beryl AX.
They’re in beta, not officially released yet.

When do you think a new version of firmware with the latest build will be out for the GL-AXT1800?

Please follow this post to update your Tailscale version: Script: Update Tailscale on (nearly) all devices