GL-AXT1800 VPN Policy Base on the Target Domain or IP not working

I have a GL-AXT1800, configured:
Block Non-VPN Traffic switched on
Accessing Following Domain/IP: Not use VPN
192.168.0.2 listed

But I cannot access 192.168.0.2 with this configuration. In my previous Brume, I could use the kill switch and set 192.168.0.2 as an exception no problem.

Block Non-VPN Traffic / Kill Switch changed in Firmware 4 that takes precedence over VPN policy:

I do not work for and I am not directly associated with GL.iNet

1 Like

Thank you - so I’m not going mad. Do you have any advice please, on how I can use the kill switch while also being able to map a drive to a server on the WAN?

First, you do not need to use Killswitch (block non-vpn traffic). If you enable vpn it has killswitch already.
The “block non-vpn traffic” does exactly it shows, you have to use vpn.

Second, to access the WAN, do not need to use vpn policy. Go to Global options and enable “allow access wan”.

Hi,
If I interrupt the VPN (incorrect password, or switch VPN connectors), traffic goes out directly resulting in leaking. Therefore there is no automatic kill switch?

This should not be the case. In case of vpn enabled but failed, you should not have data leak.

Can you check and give the steps?

Hi,
If I switch from one VPN to another, while pinging 8.8.8.8, the router continues to allow the ping out while the VPN is down.

What is your firmware version?

This should not be the case.

This is what happening in my firmware when I change wireguard profile.