GL-AXT1800 VPN Policy-based do not work with adguard

If you configure policies and enable adguard, then after rebooting the router, the policy stops working.
If you disable adguard, vpn domain name policies work again. This seems to be due to an added forward rule on port 3053

1 Like

Removing the forwarding rule on 3053 port fix this problem

Thanks for your feedback.
This port forwarding is to display the client IP in ADGuard Home. It will let DNS resolution be processed fully by ADGuard Home, resulting in the Domain Name Policy being invalidated.
We will provide options in the page.

1 Like

So you are working to have some options that work with adguard showing the clients with VPN with rules?

Because I could use NextDNS with the VPN rules but I really would like to see that feature with adguard + vpn

The option currently offered is only an EITHER option. The only thing that conflicts with the ADGuard Home display of the client list is the domain based VPN policy. Users can only choose to use one of these. However, other policies can already be used with it.
There are no good ideas for resolving this conflict.

noted, and Do you recommend any configuration like that, I just need that two websites I use do not use the vpn, sorry if I am using the post of you [username091]

You should not turn this option on in the new firmware.

1 Like

Is this a beta version right? Is it working well with mullvad? I tried it in a couple weeks ago and did not work, I will try again

So if I understood the adguard home will see all the my clients individually and the VPN policy will work normally, I just don’t need to enable this option?

The weird thing that I added nextdns app from aplications and activacted the dns in luci and I could see all my clients individually and the vpn over policy works normally.

It is the beta version.
Yes, this option is turned off by default.

Hello, I upgrade to the version beta, but I couldn’t find the option of the picture you shared to enable or disable

It is on the ADGuard Home page, you need to enable ADGuard Home to see it.