GL-AXT1800 Wireguard not working

Been trying to get my GL-AXT1800 to work with wireguard client. Ive tried 2 VPN services TorGuard and PrivateInternetAccess. They both connect, but then there is no internet connectivity. I have updated the firmware, restarted the router, and reset it. I am importing the .confg files generated from the VPN sites because im using a dedicated IP. I have tried it without the dedicated IP aswell still wont work.

Anyone have any ideas? Im about to return this thing to amazon :frowning:

I am having the exact same problem using NordVPN and KeepSolid VPN. I’m curious how to solve it as well!

I think i found a fix. I setup the dns manually on the router to googles public dns and then connected, now it works.

Its and

Hopefully they fix this though

1 Like

These are the public DNS routers from Google. It is not bad, because it is working. But it is also not in any sense ‘privacy’.
Overall is it a dirty hack or a workaround. In no case I would give it the description ‘fix’.

To understand the basic issue, what was the DNS setup before?

definitely not a fix but sign of another vulnerability in wireguard.
I reported to NordVpn and Keepsolid but they play dumb.
Switched to protonvpn and works

I just added dnsmasq to my wireguard server, and then use that (with the wireguard-private ip address) as the dns server.

When you have problem for Wireguard connects but not Internet, here are two troubleshoot directions:

  1. Check if the wireguard has keepalive settings. If not just add value 25. I think we forced this in 4.x but better check.
  2. Check dns settings. If the wireguard does not have DNS settings, maybe just set up a custom dns in the router. Better encrypted DNS.

Where do I check that setting and how do I change it? Is there a command to use via ssh? Luci?

In the Wireguard client section you can edit Wireguard config by items. Can you find it?

I’m using OpenVPN by NordVPN. I looked at the config file and did not see a keepalive setting. Do I just add “keepalive 25” to it?

Openvpn is another story.

We were talking about Wireguard.

But pls add keepalive to the openvpn as well.
For openvpn, you need to add two lines like this

   ping 10                    # Argument: interval
   ping-restart 60            # Argument: timeout