Gl-B1300 guest network

Has anyone been able to setup a guest network on a Gl-B1300 mesh network?

I fallowed the steps on the OpenWRT Wiki but I had problems getting an ipv4 addresses and that was before I even connected 2 of the routers. So any advice would be great.

I can start to connect to the new network but I can’t get an ip address

Could you show me the firewall/wireless/dhcp/network configuration files?

cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/wireless
cat /etc/config/firewall

Sorry about the delay.

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'auto'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-B1300-480-5G'
	option ieee1905managed '1'
	option ipaddr '192.168.9.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-B1300-480-5G'
	option custom_dns '1'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '1'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '2'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '3'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '4'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '5'
	option mode 'dscp'
	option status 'enable'

config interface 'hguest'
	option proto 'static'
	option ipaddr '192.168.10.0'
	option netmask '255.255.255.0'

cat /etc/config/dhcp

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'auto'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-B1300-480-5G'
	option ieee1905managed '1'
	option ipaddr '192.168.9.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-B1300-480-5G'
	option custom_dns '1'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '1'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '2'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '3'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '4'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '5'
	option mode 'dscp'
	option status 'enable'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.10.0'
	option netmask '255.255.255.0'

cat /etc/config/wireless

config wifi-device 'wifi0'
	option type 'qcawifi'
	option channel 'auto'
	option hwmode '11ng'
	option disabled '0'
	option txpower '20'
	option macaddr 'e6:95:6e:43:34:80'
	option repacd_auto_create_vaps '0'
	option htmode 'HT40'
	option qwrap_dbdc_enable '0'
	option dbdc_enable '0'

config wifi-iface
	option device 'wifi0'
	option network 'lan'
	option mode 'ap'
	option blockdfschan '1'
	option wds '1'
	option ifname 'ath0'
	option athnewind '1'
	option backhaul_ap '0'
	option backhaul '0'
	option disablecoext '1'
	option wps_pbc '0'
	option wps_pbc_enable '0'
	option wps_pbc_start_time '0'
	option wps_pbc_duration '120'
	option disabled '0'
	option qwrap_ap '0'
	option rrm '1'
	option extap '0'
	option ssid 'GL-B1300'
	option key 'password removed'
	option encryption 'psk2+ccmp'

config wifi-device 'wifi1'
	option type 'qcawifi'
	option hwmode '11ac'
	option disabled '0'
	option txpower '20'
	option htmode 'VHT80'
	option macaddr 'e6:95:6e:43:34:81'
	option repacd_auto_create_vaps '0'
	option qwrap_enable '0'
	option dbdc_enable '0'
	option channel '120'

config wifi-iface
	option device 'wifi1'
	option network 'lan'
	option mode 'ap'
	option blockdfschan '1'
	option ifname 'ath1'
	option wds '1'
	option athnewind '1'
	option backhaul_ap '0'
	option backhaul '0'
	option wps_pbc '0'
	option wps_pbc_enable '0'
	option wps_pbc_start_time '0'
	option wps_pbc_duration '120'
	option disabled '0'
	option qwrap_ap '0'
	option rrm '1'
	option extap '0'
	option key 'password removed'
	option ssid 'GL-B1300'
	option encryption 'psk2+ccmp'

config wifi-iface 'bh_ap_wifi0'
	option device 'wifi0'
	option network 'lan'
	option mode 'ap'
	option disabled '0'
	option repacd_security_unmanaged '1'
	option wds '1'
	option backhaul_ap '1'
	option ssid 'OpEbdttmh3k9'
	option encryption 'psk-mixed'
	option blockdfschan '1'
	option key 'password removed'
	option athnewind '0'
	option hidden '1'
	option ifname 'ath01'
	option qwrap_ap '0'
	option rrm '1'
	option extap '0'

config wifi-iface 'bh_sta_wifi0'
	option device 'wifi0'
	option mode 'sta'
	option repacd_security_unmanaged '1'
	option wds '1'
	option ssid 'OpEbdttmh3k9'
	option encryption 'psk-mixed'
	option key 'password removed'	
	option ifname 'ath02'
	option wps_pbc '0'
	option wps_pbc_enable '0'
	option wps_pbc_start_time '0'
	option wps_pbc_duration '120'
	option disabled '1'
	option extap '0'
	option bssid '00:00:00:00:00:00'
	option network 'lan guest'

config wifi-iface 'bh_ap_wifi1'
	option device 'wifi1'
	option network 'lan'
	option mode 'ap'
	option disabled '0'
	option repacd_security_unmanaged '1'
	option wds '1'
	option backhaul_ap '1'
	option ssid 'OpEbdttmh3k9'
	option encryption 'psk-mixed'
	option blockdfschan '1'
	option key 'password removed'
	option athnewind '0'
	option hidden '1'
	option ifname 'ath11'
	option qwrap_ap '0'
	option rrm '1'
	option extap '0'

config wifi-iface 'bh_sta_wifi1'
	option device 'wifi1'
	option network 'lan'
	option mode 'sta'
	option repacd_security_unmanaged '1'
	option wds '1'
	option ssid 'OpEbdttmh3k9'
	option encryption 'psk-mixed'
	option key 'password removed'
	option ifname 'ath12'
	option wps_pbc '0'
	option wps_pbc_enable '0'
	option wps_pbc_start_time '0'
	option wps_pbc_duration '120'
	option disabled '1'
	option extap '0'

config wifi-iface
	option device 'wifi0'
	option mode 'ap'
	option ssid 'guest'
	option key 'password removed'
	option encryption 'psk2+ccmp'

cat /etc/config/firewall

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'DROP'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fe80::/10'
	option src_port '547'
	option dest_ip 'fe80::/10'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule 'glservice_rule'
	option name 'glservice'
	option dest_port '83'
	option proto 'tcp udp'
	option src 'wan'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option target 'ACCEPT'
	option proto 'tcp udp'
	option dest_port '53'
	option name 'guest-DNS'
	option src 'guest'

config rule
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option family 'ipv4'
	option dest 'guest'
	option dest_port '68'
	option name 'guest-DHCP-renew'

config rule
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option name 'Guest-DHCPv6'
	option family 'ipv6'
	option src_port '547'
	option dest 'guest'
	option dest_port '546'

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option disabled '0'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option input 'DROP'
	option forward 'DROP'
	option network 'wan wan6'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'qcanssecm'
	option type 'script'
	option path '/etc/firewall.d/qca-nss-ecm'
	option family 'any'
	option reload '0'

config include 'shadowsocks'
	option type 'script'
	option path '/var/etc/shadowsocks.include'
	option reload '1'

config zone
	option forward 'REJECT'
	option output 'ACCEPT'
	option name 'guest'
	option input 'REJECT'
	option network 'guest'

config forwarding
	option dest 'wan'
	option src 'guest'

config forwarding
	option dest 'wan'
	option src 'lan'

PS after fallowing the steps on the OpenWRT wiki and double checking them and it still didn’t work I then compared the settings for the new gust network to the setting for the already existing networks and made some changes which is what you’re seeing here.

Thank you

Sorry for reply late. Here is part of my configurations are different to yours.

/etc/config/network

config interface 'guest'
	option ifname 'guest'
	option proto 'static'
	option type 'bridge'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

/etc/config/wireless

config wifi-iface
	option device 'wifi1'
	option network 'guest'
	option mode 'ap'
	option blockdfschan '1'
	option ssid 'GL-B1300-006-Guest'
	option encryption 'psk-mixed'
	option key 'goodlife'
	option wds '1'
	option ifname 'ath2'
	option athnewind '1'

Thank you so far it looks like it’s working I’ll need to test a few things later. I’m not sure if it’s working on both routers but I’ll test that out and post later.

I was wrong it’s not working. I’m still only able to connect using DHCPv6 on my computer and I can’t connect at all on my phone (Which makes sense because I don’t believe that Android supports DHCPv6). I’ve double checked for typos using diff but it’s still not working. I’m wondering if I need to start over and try again? Any advice would be great.

Thank you again for trying to help me.

Do you mean you can’t connect to guest SSID when you use your phone? What does it hint? Does IPv4 work?

When I trying to connect to the guest SSID on the phone it just says “obtaining IP address…” but it never connects. When I connect to guest on a pc it connects but only with an IPV6 address (no IPV4 address) and it doesn’t actually connect to the internet. This is only an issue with the guest network.

Is the dhcp configuration correct?

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option dhcpv6 'server'
	option ra 'server'

This is what it looked like before

config dhcp 'guest'
		option interface 'guest'
		option start '100'
		option leasetime '12h'
		option limit '150'
		option dhcpv6 'server'
		option ra 'server'
		option ra_management '1'

Then I removed

option ra_management ‘1’

so that it matched yours and rebooted the router but it didn’t help