GL-B1300 - lighthttpd logging

Router Model: GL.iNet GL-B1300
Firmware version: 3.027

I am unable to get lighthttpd to send it’s logs to syslog, so the can be seen by logread and sent to my remote syslog server.

Here is what I added to /etc/lighttpd/lighttpd.conf to try and get it working:

#accesslog.filename = “/var/log/lighttpd/access.log”
accesslog.syslog-level = “7”
accesslog.use-syslog = “enable”
#server.errorlog = “/var/log/lighttpd/error.log”
server.errorlog-use-syslog = “enable”
server.breakagelog = “enable”
server.syslog-facility = “daemon”
debug.log-request-header = “enable”
debug.log-condition-handling = “enable”
debug.log-ssl-noise = “enable”
debug.log-request-handling = “enable”

How can I get the logging in lighthttpd to work?

I tried on my AR750s


I have error log in syslog but no acceslog. Seems this is not compiled in.

You might have to install it?:

opkg update && opkg install lighttpd-mod-accesslog

Update: I just tried it on another GL-B1300 we have, and it works!

So the router it isn’t working on is meshed…is that the issue?

Mesh should not be the problem. Not sure.