GL-B2200 Did not complete firmware upgrade

It looks like the firmware upgrade of 1 of my mesh nodes hasnt completed properly. It is at the previous level of firmware that the master upgraded from. It looked it was flashing the firmware but didnt complete for well over 30 minutes. I rebooted it and it seems to be working but I can’t get into the web interface. The HTML page keeps reloading and I can’t login, it is at the choose a language page.

I have reset the router using the reset button on the back but still get the same symptoms.

Current FW version is 3.212 of child node (broken one)
Current FW version of Main Node is 3.215


I had to reset, set it up as a router but not in mesh mode and login locally to it and then upgrade the firmware.

I had this same situation. I could upgrade the firmware by setting it up as an individual router, but I was unable to then link it to the mesh network. I couldn’t see anything wrong in the logs, so I’m assuming it’s a hardware issue. I tried every available firmware release. I then returned it and purchased another. The new one links to the mesh network fine and will upgrade itself automatically.