GL-B2200 Issues and Frustrations

I have 4x GL-B2200 units that I picked up when they were on pre-order due to how well all the other Gl-iNet routers have worked for me. They have worked flawlessly for me till this last year. For some reason, randomly when I enable or disable the VPN, the units seem to corrupt themselves. Sometimes after disabling the VPN I have to change my DNS from Encrypted (NEXTDNS) to Automatic and then back to get the internet to work again. This last time, I enabled the VPN (Surfshark Wireguard) and the Sub-Notes corrupted the WPS passwords and nothing could connect to the sub nodes. I changed the passwords in the main unit, along with the SSID and nothing would fix the sub nodes. I had to reset the whole network and re-build it from factory reset. This year I have to factory reset the firmware 6 times on all the units to fix some issue with the mesh network. I am not sure if it is due to the IOS app or firmware corrupting the firmware, but I am very frustrated. I even tried re-flashing all the units with Uboot and changing the master unit. This has not resolved any of the issues. Some issues with the IOS App that I always have is it shows a yellow exclamation mark next to Ethernet (Network → Internet) why… I have no idea, it is just DHCP internet. The app shows an error next to time zone… why?.. no idea. I just want to have a mesh network that I can run NextDNS, that I can enable and disable the VPN easily. The amount of random issue I have with the GL-B2200 makes me want to give up on them. Am I the only one that is having these issues with the GL-B2200? Can someone give me some tips or tell me what I am doing wrong? Is this an abandoned product?

Although I cannot help you with the issue involving the vpn and corrupt passwords, which might be the sign of a poorly router, I can tell you the the app on Android is slow to respond and gather the data from the routers via cloud. It may take a minute or two for it to settle down. The app doesn’t always get things correct either and you are best checking the information given by the app against the router admin page or luci. Luci is ALWAYS correct, but hard to understand.

As for borking the wps passwords, that sounds like something you’d have to check with developers. Not sure if there’s a github or anything like that to report faults but you might find your answer there.


what is the firmware version of your devices?

They are all on Firmware 3.216.